Author Topic: Wrong status protocols  (Read 4266 times)

0 Members and 1 Guest are viewing this topic.

Offline borutTopic starter

  • Newbie
  • *
  • Posts: 32
  • Country: pl
  • Karma: 0
  • Version Info
Wrong status protocols
« on: 08 01 2016, 11:25:42 »
For some time the contacts available (all protocols) have the status offline. Only when you change the "hide offline contacts" and returning to the "Show offline contacts", everything goes back to normal. Please improve.
 

Offline Vulpix

Re: Wrong status protocols
« Reply #1 on: 08 01 2016, 14:11:48 »
Is it http://forum.miranda-ng.org/index.php?topic=4353.msg14885#msg14885 ?

I find that anything that "refreshes" the contact list temporarily fixes the issue.
 
The following users thanked this post: borut

Offline borutTopic starter

  • Newbie
  • *
  • Posts: 32
  • Country: pl
  • Karma: 0
  • Version Info
Re: Wrong status protocols
« Reply #2 on: 08 01 2016, 18:43:48 »
The Guide did not help.  :(
« Last Edit: 08 01 2016, 18:47:36 by borut »
 

Offline Vulpix

Re: Wrong status protocols
« Reply #3 on: 08 01 2016, 19:30:16 »
The Guide did not help.  :(

? what guide.

There is no guide :3 This is an unfixed bug and nothing you can do to fix it. You can "temporarily" fix it by doing anything that refreshes the contact list - such as switching offline/online contact display or changing display lines. Sadly :(
 

Offline Robyer

Re: Wrong status protocols
« Reply #4 on: 09 01 2016, 10:31:03 »
Vulpix, is it easily reproducible (how often it happens)? Do you remember when it started? Does it work in latest stable or is it much older? Is it problem only of clist_modern or does it affect other clists as well?
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline Vulpix

Re: Wrong status protocols
« Reply #5 on: 09 01 2016, 11:17:09 »
Vulpix, is it easily reproducible (how often it happens)? Do you remember when it started? Does it work in latest stable or is it much older? Is it problem only of clist_modern or does it affect other clists as well?

I gave wishmaster a CLEAN profile where you can reproduce it 10/10 times.

I think it started about 2 or 3 months ago.

I don't know if it works in latest stable, I cannot check though since most of the protocols I use don't work there.

I don't know, I only use clist_modern, but I could try if you want.
 

Offline Wishmaster

Re: Wrong status protocols
« Reply #6 on: 09 01 2016, 11:24:42 »
I gave wishmaster a CLEAN profile where you can reproduce it 10/10 times.
What?  ???
 

Offline borutTopic starter

  • Newbie
  • *
  • Posts: 32
  • Country: pl
  • Karma: 0
  • Version Info
Re: Wrong status protocols
« Reply #7 on: 09 01 2016, 11:53:29 »
Today these tips is better, because only Facebook hangs on "Offline"  :-\
 

Offline Goraf

Re: Wrong status protocols
« Reply #8 on: 09 01 2016, 12:03:28 »
As far as I remember it was working in dev version
http://trac.miranda-ng.org/ticket/1104

And this bug can't be older than 2 to 3 months (like Vulpix said)
« Last Edit: 09 01 2016, 12:17:03 by Goraf »
 
The following users thanked this post: borut

Offline borutTopic starter

  • Newbie
  • *
  • Posts: 32
  • Country: pl
  • Karma: 0
  • Version Info
Odp: Wrong status protocols
« Reply #9 on: 09 01 2016, 12:08:11 »
Still exists in version "0. 95. 5 alpha build # 16064"
 

Offline Robyer

Odp: Wrong status protocols
« Reply #10 on: 09 01 2016, 12:37:09 »
It would be good to find the particular commit which introduced this problem. We can ask watcher to prepare us various releases from different commits so you (anybody interested) can test it and narrow down the time when it started.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline Vulpix

Re: Wrong status protocols
« Reply #11 on: 09 01 2016, 15:42:49 »
What?  ???

Sorry, not wishmaster D: Watcher. You both start with W, and I was tired.

Also what is this vote :D do you have a problem with this thread? :D
« Last Edit: 09 01 2016, 15:44:26 by Vulpix »
 

Offline Vulpix

Re: Wrong status protocols
« Reply #12 on: 09 01 2016, 18:19:01 »
As far as I remember it was working in dev version
http://trac.miranda-ng.org/ticket/1104

And this bug can't be older than 2 to 3 months (like Vulpix said)

This is when I spoke about it with Watcher:
Vulpix, 04.11.2015 14:20:07:
Do you also have that issue with statuses?

Vulpix, 14:20:11:
in miranda

Vulpix, 14:20:14:
If you use row items?

Vulpix, 14:20:30:
I dunno if I should create a ticket or leave it on the forums, but it's pretty annoying

So that's 2 months ago, it was there for a few days already when it started bugging me.


It should be one of these, I'm guessing?:

http://trac.miranda-ng.org/changeset/15652
http://trac.miranda-ng.org/changeset/15631

Maybe:

   int GetStatusForContact(MCONTACT hContact, char *szProto)
315   315   {
316    -           return (szProto) ? (int)(db_get_w(hContact, szProto, "Status", ID_STATUS_OFFLINE)) : ID_STATUS_OFFLINE;
+    316           return (szProto) ? db_get_w(hContact, szProto, "Status", ID_STATUS_OFFLINE) : ID_STATUS_OFFLINE;
317   317   }
318   318   

I dunno, I'm not a programmer, not sure why the type cast would be there and then not...
« Last Edit: 09 01 2016, 18:34:29 by Vulpix »
 

Offline Wishmaster

Re: Wrong status protocols
« Reply #13 on: 09 01 2016, 19:50:02 »
Maybe:

   int GetStatusForContact(MCONTACT hContact, char *szProto)
315   315   {
316    -           return (szProto) ? (int)(db_get_w(hContact, szProto, "Status", ID_STATUS_OFFLINE)) : ID_STATUS_OFFLINE;
+    316           return (szProto) ? db_get_w(hContact, szProto, "Status", ID_STATUS_OFFLINE) : ID_STATUS_OFFLINE;
317   317   }
318   318   

I dunno, I'm not a programmer, not sure why the type cast would be there and then not...

No idea why the cast was there, but it definately was uneeded. But both variants are correct, actually.
« Last Edit: 10 01 2016, 11:32:11 by Wishmaster »
 

Offline Goraf

Re: Wrong status protocols
« Reply #14 on: 20 01 2016, 17:57:43 »
I've found it in the first shot  ;D  Vulpix gave me enough info in his posts. The problem is in:

http://trac.miranda-ng.org/changeset/15652


15651 - working
15653 - not working
 
The following users thanked this post: Robyer