Author Topic: Steam protocol  (Read 112783 times)

0 Members and 1 Guest are viewing this topic.

Offline Vulpix

  • Beta Tester
  • *****
  • Posts: 618
  • Country: 00
  • Karma: 15
Re: Steam protocol
« Reply #420 on: 22 03 2017, 16:34:20 »
Can you post the details?

miranda version info+netlog?

It's working fine for me so maybe it's something specific to your account or operating system. Otherwise please log a github ticket (but with the info I requested as well!)

Thanks!
 

Offline SpinalBlood

  • Full Member
  • ***
  • Posts: 128
  • Country: it
  • Karma: 1
Re: Steam protocol
« Reply #421 on: 22 03 2017, 17:26:10 »
VersionInfo
Quote (selected)
CPU: Intel(R) Core(TM) i5-3450 CPU @ 3.10GHz [Intel64 Family 6 Model 58 Stepping 9] [DEP Enabled] [4 CPUs]
Installed RAM: 3792 MBytes
Microsoft Windows 7 Ultimate Edition, 64-bit Service Pack 1 (build 7601)
Internet Explorer: 9.11.9600.17801 (build 99600)
Administrator privileges: Yes
OS Languages: (UI | Locale (User/System)) : Italian/Italian | Italian/Italian
Free disk space on Miranda partition: 91557 MBytes

Miranda NG Version: 0.95.6 alpha build #17953 (75876f6) [running inside WOW64]
Build time: 22 Mar 2017 9:52:08
Profile: C:\Program Files (x86)\Miranda\Profiles\temp\temp.dat (dbx mmap driver)
Profile size: 131072 Bytes
Profile creation date: 22 Mar 2017 18:00:08
Language pack: No language pack installed
Service Mode: No

Active Plugins (16):
¤ AdvaImg.dll v.0.11.0.2 [13 Jan 2017 5:01:19] - Miranda image services
¤ AVS.dll v.0.95.3.4 [22 Mar 2017 9:47:36] - Avatar service
¤ Clist_modern.dll v.0.9.1.5 [22 Mar 2017 9:49:22] - Modern contact list
¤ CrashDumper.dll v.0.0.5.2 [13 Jan 2017 5:01:53] - Crash dumper
¤ DbEditorPP.dll v.4.0.1.1 [4 Jan 2017 8:36:36] - Database editor++
¤ Dbx_mmap.dll v.0.95.3.1 [22 Mar 2017 9:47:40] - Miranda NG mmap database driver
¤ HistoryPP.dll v.1.5.1.5 [9 Feb 2017 18:55:12] - History++
¤ Import.dll v.0.95.4.3 [18 Jan 2017 4:00:10] - Import contacts and messages
¤ NewXstatusNotify.dll v.1.4.0.11 [18 Jan 2017 4:01:00] - xStatus notify
¤ PluginUpdater.dll v.0.1.2.5 [13 Jan 2017 5:02:06] - Plugin updater
¤ Popup.dll v.2.1.1.12 [18 Jan 2017 4:01:10] - Popup plus
¤ SeenPlugin.dll v.5.0.5.2 [3 Dec 2016 4:01:06] - Last seen
¤ StatusManager.dll v.0.11.2.0 [12 Feb 2017 4:04:14] - Status manager
¤ Steam.dll v.0.11.6.1 [18 Jan 2017 4:03:58] - Steam protocol
¤ TabSRMM.dll v.3.5.0.4 [22 Mar 2017 9:47:52] - TabSRMM
¤ TopToolBar.dll v.0.8.0.4 [13 Jan 2017 5:01:35] - TopToolBar

Unloadable Plugins (1):
¤ DbChecker.dll v.0.0.0.0 [22 Mar 2017 9:49:38] - <unknown>


Protocols and Accounts:
-------------------------------------------------------------------------------
STEAM                    1 - Enabled 0 - Disabled  Loaded
MetaContacts             1 - Enabled 0 - Disabled  Loaded

Icon Packs:
-------------------------------------------------------------------------------
 HistoryPP_icons.dll [10 Feb 2017 4:02:16]
 Proto_AIM.dll [22 Mar 2017 9:49:12]
 Proto_Facebook.dll [22 Mar 2017 9:49:10]
 Proto_GG.dll [31 Jan 2017 4:01:38]
 Proto_ICQ.dll [21 Feb 2017 4:01:40]
 Proto_IRC.dll [22 Mar 2017 9:49:12]
 Proto_Jabber.dll [22 Mar 2017 9:49:12]
 Proto_MetaContacts.dll [22 Mar 2017 9:51:20]
 Proto_MSN.dll [22 Mar 2017 9:49:12]
 Proto_Skype.dll [22 Mar 2017 9:51:34]
 Proto_Steam.dll [18 Jan 2017 4:03:52]
 Proto_Tox.dll [22 Mar 2017 9:51:36]
 Proto_Yahoo.dll [23 Sep 2016 3:01:40]
 Proto_YAMN.dll [14 Jan 2017 4:02:30]
 TabSRMM_icons.dll [22 Mar 2017 9:49:54]
 Toolbar_icons.dll [22 Mar 2017 9:49:12]
 Watrack_buttons.dll [18 Jan 2017 4:04:42]
 Watrack_icons.dll [18 Jan 2017 4:04:42]
 xStatus_ICQ.dll [21 Feb 2017 4:00:32]
 xStatus_Jabber.dll [22 Mar 2017 9:47:58]

Network log attached;

(at 18:16:33 I manually close Miranda)

I notice these:

[18:16:16 05FC] [STEAM_1] CSteamProto::OnAuthorizationError: The account name or password that you have entered is incorrect.
[18:16:16 05FC] [STEAM_1] CSteamProto::OnAuthorizationError: clear password field

but, the password is NOT incorrect

(on a side/offtopic note I wonder why DbChecker.dll cannot be loaded...)
 

Offline Vulpix

  • Beta Tester
  • *****
  • Posts: 618
  • Country: 00
  • Karma: 15
Re: Steam protocol
« Reply #422 on: 22 03 2017, 17:36:57 »
Dbchecker is only loaded on a special start (when you restart miranda in database checker mode, or by using a startup parameter for the miranda executable). It's normal to see it unloaded.

Do you use anything special on your account? Maybe the mobile guard or something like that?
 

Offline SpinalBlood

  • Full Member
  • ***
  • Posts: 128
  • Country: it
  • Karma: 1
Re: Steam protocol
« Reply #423 on: 22 03 2017, 18:03:11 »
I have the send Steam Guard codes to email option enabled, but I had it since years and it wasn't a problem before. Now I have disabled Steam Guard, but it still isn't working.

Dbchecker is only loaded on a special start (when you restart miranda in database checker mode, or by using a startup parameter for the miranda executable). It's normal to see it unloaded.

Thanks
 

Offline Vulpix

  • Beta Tester
  • *****
  • Posts: 618
  • Country: 00
  • Karma: 15
Re: Steam protocol
« Reply #424 on: 22 03 2017, 18:14:39 »
Regular steam guard should be working, I use it too. Well, I guess you will have to log an issue for this.

You can also use dbeditor++ to navigate to your steam account and doubleclick the password field to view it to make extra sure it is your, correct password.
« Last Edit: 22 03 2017, 18:16:23 by Vulpix »
 

Offline Robyer

  • Hero Member
  • *****
  • Posts: 1082
  • Country: cz
  • Karma: 60
    • Robyer.cz website
  • Version Info
Re: Steam protocol
« Reply #425 on: 23 03 2017, 19:47:13 »
SpinalBlood, do you have somehow special password? Special chars or length? Maybe try to change your password and re-verify if that makes any change in Miranda.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline Robyer

  • Hero Member
  • *****
  • Posts: 1082
  • Country: cz
  • Karma: 60
    • Robyer.cz website
  • Version Info
Re: Steam protocol
« Reply #426 on: 23 03 2017, 19:50:06 »
Robyer, It's been 2 years and I'm still having the issue with steam guard window.
Today I had to type in 4 different steam guard codes and it only worked at 5th time - when I restarted miranda and entered yet another code.
Will you ever fix this bullshit? It's REAL pain in the ass.
It happens after running miranda for long time [Started timestamp: 12:34:05   2017-03-14]
See netlogs
VersionInfo

Well, in your logs is many times noted "<h1>Internal Server Error</h1>Failed to forward request message to internal server" so that doesn't seem to be problem in Miranda, but rather on Steam server. Even once in the "success" log. Are you sure it is problem in plugin and not some coincidence?
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline SpinalBlood

  • Full Member
  • ***
  • Posts: 128
  • Country: it
  • Karma: 1
Re: Steam protocol
« Reply #427 on: 23 03 2017, 22:25:08 »
You can also use dbeditor++ to navigate to your steam account and doubleclick the password field to view it to make extra sure it is your, correct password.

Thanks, I tried but it was the correct one

SpinalBlood, do you have somehow special password? Special chars or length? Maybe try to change your password and re-verify if that makes any change in Miranda.

I had a pretty simple password. Now I have changed it in a more complex one (a range of 15-20 chars but no special ones) since I already wanted to regardless, but still didn't help. But if the password was the problem then it wouldn't have happened earlier with the simpler one, that always worked for a while. Both old and new passwords worked in the website login
« Last Edit: 23 03 2017, 22:28:23 by SpinalBlood »
 

Offline Robyer

  • Hero Member
  • *****
  • Posts: 1082
  • Country: cz
  • Karma: 60
    • Robyer.cz website
  • Version Info
Re: Steam protocol
« Reply #428 on: 23 03 2017, 23:00:26 »
SpinalBlood, so you can login with exactly same username and password here? https://steamcommunity.com/mobilelogin/

Vulpix, have you tried whole login from "clean" account? Does that work?
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline Vulpix

  • Beta Tester
  • *****
  • Posts: 618
  • Country: 00
  • Karma: 15
Re: Steam protocol
« Reply #429 on: 23 03 2017, 23:17:11 »
Vulpix, have you tried whole login from "clean" account? Does that work?

I don't have a problem with Steam though. But I actually tried this just now (with a clean miranda where I never had any steam accounts ever before) - it correctly logged me in (after I entered the steam guard key which arrived in an e-mail almost instantly after the login attempt).
 

Offline SpinalBlood

  • Full Member
  • ***
  • Posts: 128
  • Country: it
  • Karma: 1
Re: Steam protocol
« Reply #430 on: 26 03 2017, 23:54:25 »
SpinalBlood, so you can login with exactly same username and password here? https://steamcommunity.com/mobilelogin/

Yes
 

Offline Robyer

  • Hero Member
  • *****
  • Posts: 1082
  • Country: cz
  • Karma: 60
    • Robyer.cz website
  • Version Info
Re: Steam protocol
« Reply #431 on: 28 03 2017, 20:57:50 »
SpinalBlood, that's just weird. In any case, make a ticket on Github (https://github.com/miranda-ng/miranda-ng/issues), co se won't forget that. I don't have much time for Miranda lately...
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline SpinalBlood

  • Full Member
  • ***
  • Posts: 128
  • Country: it
  • Karma: 1
Re: Steam protocol
« Reply #432 on: 28 03 2017, 23:51:58 »
I'll try tomorrow on another pc but I doubt that will change something, after that I will open the ticket

Also, I know another user who has the same problem
 

Offline SpinalBlood

  • Full Member
  • ***
  • Posts: 128
  • Country: it
  • Karma: 1
Re: Steam protocol
« Reply #433 on: 29 03 2017, 13:43:12 »
I have tried in Windows XP and it doesn't work, but this time I got an error message that for some reason I don't get in Windows 7 (Steam just doesn't work, without showing messages):

Warning:
SSL connection failure (80090326 377): Il messaggio ricevuto era imprevisto o con formattazione scorretta.

(it says the received message was unexpected or with wrong formatting)
 

Offline Robyer

  • Hero Member
  • *****
  • Posts: 1082
  • Country: cz
  • Karma: 60
    • Robyer.cz website
  • Version Info
Re:Steam protocol
« Reply #434 on: 29 03 2017, 18:45:46 »
Do you use OpenSSL plugin?
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.