Author Topic: Miranda crashing every time something is pasted into a message window  (Read 909 times)

0 Members and 1 Guest are viewing this topic.

Offline ellickTopic starter

This started happening just today, December 4 2020.   After being notified of a lot of updates, I let miranda auto update and now the program crashes every time I paste text into a contact's message window.  It's happening on both Facebook and ICQ protocols.
 

Offline ghazan

ellick,
is crash log available? (if you have a CrashDumper plugin, of course. if you haven't, you can grab it here: https://wiki.miranda-ng.org/index.php?title=Crash_reports/en#Install_CrashDumper)
 

Offline ellickTopic starter

I installed the crashdumper plugin and enabled the developers release with debug symbols option.  I had been using only stable releases before this.  I can replicate the crash every time with either.   Unfortunately the crashlog file that's generated says it's 0 bytes.    I thought I could open it in notepad and at least see something but it's blank.

This is the 32bit version of Miranda NG on windows 10.  I had a backup of the previous version before these updates.  I reverted to that and pasting text into message windows works fine again.
« Last Edit: 06 12 2020, 01:29:46 by ellick »
 

Offline ghazan

ellick,
empty crash log means that crash is too hard, like stack overflow etc.
what you can try to do is to compact that profile (main menu -> Database -> Compact), it might help
 

Offline ellickTopic starter

i ran the compact of the database.  It was instant but the crash log is still 0bytes when I replicate the crash by pasting some text into a message window.   
I wish i could give more info.  I did notice the miranda32.exe file was updated along with a lot of other things.   If i revert to my backup of Miranda, NG  the problem disappears.  The backup is v0.95.12.1 build #23277     
The problem build is v0.95.13 build #23507 but it's now the alpha, developers build since I tried upgrading to that.  It was a stable build that caused the problem.
Pasting text into message windows is something I do a lot so I noticed it almost instantly. 
 

Offline ghazan

ellick,
What about new stable build, v0.95.12.1 build #23280? Does it fail?

Also, attach your VersionInfo, please, I strongly suspect that some application might install its own hook to Miranda's window
 

Offline ellickTopic starter


Since this is a portable install, I save the whole folder to back it up. 

v.0.95.12.1 build 23277   works fine.   No problem pasting text to any message windows.

As soon as I let the plugin updater auto-update to
v0.95.12.1 build 23280  it crashes every time I paste text to a message window.

version info for the 23280 build file attached:
 

Offline ghazan

ellick,

well, I advice you to remove all these old files first:

Unloadable Plugins (7):
¤ AutoLoadAvatars.dll v.0.0.0.0 [24 Oct 2004 3:05:16] - <unknown>
¤ changeinfo.dll v.0.0.0.0 [16 Jun 2005 13:39:02] - <unknown>
¤ contactvisibility.dll v.0.0.0.0 [15 May 2003 14:34:38] - <unknown>
¤ help.dll v.0.0.0.0 [19 Dec 2006 23:02:26] - <unknown>
¤ ImgLib.dll v.0.0.0.0 [22 Oct 2004 6:11:28] - <unknown>
¤ loadavatars.dll v.0.0.0.0 [19 Dec 2006 23:02:34] - <unknown>
¤ PNGImg.dll v.0.0.0.0 [19 Jul 2004 12:29:00] - <unknown>

I don't know if they could affect Miranda.

Second, you cut out the section of loaded dlls. You can skip all modules from C:\Windows\System32 (or whatever they are located), but I need list of all another modules which are loaded inside your Miranda
 

Offline ellickTopic starter

Sorry, i didn't realize "store to file" from the version menu would cut anything.  I chose the "show with DLLs" option this time.

I will remove those files you suggest also.  My miranda folder is VERY fold so I was sure a lot of things are probably out of date.  i think I originally chose to upgrade to NG from within the old version.  I only keep it because I have it customized to my liking and there's no way I'd remember how to do it all again.  :D

Thank you for your help with this. Since no one else is mentioning this bug It may be something particular to me

edit:
I deleted all the dll files you listed above but build 23280 still crashes when pasting text.
« Last Edit: 06 12 2020, 17:58:53 by ellick »
 

Offline ghazan

ellick,
My miranda folder is VERY old so I was sure a lot of things are probably out of date.
Yes, cause only me have been making commits into it since 2004 :) so people sometimes update from ancient versions of Miranda, even from ANSI ones for Windows 98.

I deleted all the dll files you listed above but build 23280 still crashes when pasting text.
Okay, then I have to ask you if you have any experience with debugging? :) Do you have Visual Studio or Windows Debugging Tools from Windows SDK at least?
 

Offline ellickTopic starter

I do not have any experience with debugging.  :/   but my miranda folder definitely qualifies as ancient.  I was using it in windows 98 but long ago converted away from ANSI  :D

I just tried a test by unchecking every dll in the plugins list to see if any old plugins might be an issue

so the only ones still checked are these which can't be unchecked
dbchecker.dll
dbx_mdbx.dll
dbx_mmap.dll

I left facebook.dll checked so I could still message someone
I then tried the same test with only icq.dll checked

even like this it crashes as soon as I try to paste any text into a message window.

Would it help to run the update on my backup folder again and only allow the main miranda32.exe file to update?  to rule that out?

edit:
I tried the above.  I ran the update on the build 23277 but this time only let the main core miranda32.exe file update.   It still crashes
« Last Edit: 06 12 2020, 18:20:55 by ellick »
 

Offline ghazan

Would it help to run the update on my backup folder again and only allow the main miranda32.exe file to update?
In fact, nope, because Miranda32.exe is just a stub for loading Miranda's core... it does nothing

Okay, let's try to settle this case without debugger first. Do the following:
- make a copy of your profile;
- launch Miranda with that copy;
- remove all accounts from a copy;
- compact database to be sure that it doesn't contain passwords etc (main menu - Database - Compact);
- zip this database and send it to me (put it on Google drive/OneDrive/DropBox/whatever and send me a link in a private message).
« Last Edit: 06 12 2020, 18:39:29 by ghazan »
 

Offline ellickTopic starter

Thanks for your help, ghazan.  I think i'm going to just delete the whole thing and start over finally.  It's been too long on this profile, I guess.

 I can't even get the database to compact without errors and no matter what I do, the 64bit version won't run at all.  It keeps telling me it needs visual C++ libraries then offers a download to install.  I go to install that and it tells me it can't because it's already there.  on and on.    Just too many problems with it
 

Offline ellickTopic starter

Ok!
v0.95.12.1 build 23280  64bit works fine starting from scratch but boy, oh boy do I hate the default look of this now.      :'(  Time to get customzing 
Thanks again for your help, ghazan.
« Last Edit: 06 12 2020, 20:55:39 by ellick »
 

Offline ellickTopic starter

ghazan,  I thought I'd let you know how this turned out.   I think my problem is from the newest scriver plugin.   I installed a fresh installation of Miranda NG 64bit and while customizing it I realized I had been using scriver.  I prefer the blinking icon message notification to the popups and tray notification of tabsrmm. 

Anyway, I installed scriver, stable version and all seemed fine.   Pasting test into message windows worked.   I noticed I was missing one customization option which is "close message window on send".   That's been there for years in my old install but the new scriver 64bit didnt have it.  I installed the developers version of scriver, 64bit and the option was there again.   Soon after installing it, I started having the crashes when pasting text again.   I went back to the stable version of scriver and the problem disappeared.

My old miranda 32bit install and the latest developers release of scriver 64bit looks like the picture on the left.   The stable 64bit options are on the right.


« Last Edit: 07 12 2020, 18:25:44 by ellick »