Author Topic: Jabber 'jid-malformed' response when sending presence  (Read 349 times)

0 Members and 1 Guest are viewing this topic.

Offline ultramageTopic starter

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
For the past 2 weeks or so, I'm unable to properly participate in the miranda-ng official chatroom.
Code: [Select]
<presence to="miranda-ng-int@conference.jabber.ru/"><priority>0</priority><x xmlns="http://jabber.org/protocol/muc"/><c xmlns="http://jabber.org/protocol/caps" hash="sha-1" node="http://miranda-ng.org/caps" ver="etVKcTpDTHcnLhFURtdNhXv+p9c=" ext="mirotr x64 mood activity mir_notes"/><x xmlns="vcard-temp:x:update"><photo/></x><x xmlns="miranda:x:vcard">798d9742b77d9971d7a2daadab48b0e3</x><status></status></presence>
<presence from='miranda-ng-int@conference.jabber.ru/' to='*******@jabber.org/Miranda' type='error'><error code='400' type='modify'><jid-malformed xmlns='urn:ietf:params:xml:ns:xmpp-stanzas'/></error></presence>
I am not sure what this means. Is the server I'm using defective? It's an old account that I started using for the sole purpose of joining the miranda chat.
 

Offline ultramageTopic starter

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
Re: Jabber 'jid-malformed' response when sending presence
« Reply #1 on: 25 09 2020, 08:32:28 »
Sorry for bumping the thread but I'd really like to see this resolved. I don't know enough about the protocol to tell which party is at fault.
 

Offline ghazan

Re: Jabber 'jid-malformed' response when sending presence
« Reply #2 on: 25 09 2020, 15:36:12 »
ultramage,
you shall add a nick to your bookmark to enter the room
 

Offline ultramageTopic starter

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
Re: Jabber 'jid-malformed' response when sending presence
« Reply #3 on: 25 09 2020, 16:15:18 »
I deleted the chatroom and added it again, based on the link on the miranda-ng website. The thing auto-populated from my clipboard.
Code: [Select]
<presence to="xmpp:miranda-ng-int@conference.jabber.ru?join/ultramage">
<priority>
0
</priority>
<x xmlns="http://jabber.org/protocol/muc" />
<c xmlns="http://jabber.org/protocol/caps" hash="sha-1" node="http://miranda-ng.org/caps" ver="pIkQaCwAC+LHTyKhh82FVQnGgo0=" ext="mirotr x64 mood activity mir_notes" />
<x xmlns="vcard-temp:x:update">
<photo />
</x>
<x xmlns="miranda:x:vcard">
798d9742b77d9971d7a2daadab48b0e3
</x>
<status>

</status>
</presence>
Code: [Select]
<presence from="xmpp:miranda-ng-int@conference.jabber.ru?join/ultramage" to="********@jabber.org/Miranda" type="error">
<error code="400" type="modify">
<jid-malformed xmlns="urn:ietf:params:xml:ns:xmpp-stanzas" />
</error>
</presence>
>:(

If I understand right, the jabber.org server talks to jabber.ru on my behalf, so it might be modifying/garbling my message on the way. I wouldn't be able to tell. It's been fine for a little while after I revived my old account, I used it to join the chatroom and I talked to you for a bit about my initial problems with the Discord plugin and how I was not able to reach cdn.discordapp.com from my current location. Afterwards, it broke and I was unable to properly re-join the chatroom. I thought it was some recent code change in Miranda-NG that broke something.
« Last Edit: 25 09 2020, 16:27:50 by ultramage »
 

Offline ghazan

Re: Jabber 'jid-malformed' response when sending presence
« Reply #4 on: 25 09 2020, 16:38:02 »
no, that's not a problem of jabber.org
"xmpp:miranda-ng-int@conference.jabber.ru?join/ultramage" is definitely a wrong JID your Miranda is sending
it shall be "miranda-ng-int@conference.jabber.ru/ultramage"
 

Offline ultramageTopic starter

  • Newbie
  • *
  • Posts: 15
  • Karma: 0
Re: Jabber 'jid-malformed' response when sending presence
« Reply #5 on: 25 09 2020, 16:47:22 »
Ah, didn't notice that it tacked on the xmpp: part. The result was the same though.
Then I read your reply closer and noticed you also removed the '?join' part. So I did the same, and I successfully got in.

I got the url from https://www.miranda-ng.org/en/development/ and I believe I've used it in the past... I guess the ?join part is supposed to be parsed by AssocMgr and removed?

PS: the 'chat logs' link for the int chatroom doesn't work. The russian one does. I tried altering the url to use the int chatroom, but it said 404. So I guess it's not being logged.
« Last Edit: 25 09 2020, 16:54:22 by ultramage »
 

Offline dartraiden

Re: Jabber 'jid-malformed' response when sending presence
« Reply #6 on: 25 09 2020, 19:41:54 »
Yes, Int room has been broken at server crash long time ago.
_██_
(°ᴗƪ)
 

Offline dartraiden

Re: Jabber 'jid-malformed' response when sending presence
« Reply #7 on: 25 09 2020, 20:02:22 »
I guess the ?join part is supposed to be parsed by AssocMgr and removed?
Yes, according to https://xmpp.org/extensions/xep-0147.html
_██_
(°ᴗƪ)