Author Topic: Jabber does not synchronize  (Read 49 times)

0 Members and 1 Guest are viewing this topic.

Offline MothTopic starter

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Jabber does not synchronize
« on: 08 08 2018, 07:37:59 »
Hey,

I recently noticed, that Miranda has omemo encryption now (I think for some time now, but it totally passed me by). I'm using Jabber on my phone with conversations and on the PC with Gajim up to now.

I got the Jabber Plugin for Miranda now, I activated the omemo encryption in the settings. I was able to send a message to my husband (he's only using Conversations), which he got, and I got his answer. But on my phone I don't see my own messages sent from Miranda.
I guess this has something to do with the Fingerprints somehow, but I can't figure out how to see and accept those on Miranda.

Then I tested with my second "Test"-JID (Shade), which I use only via Pix-Art Messenger. I added my regular account (Moth) via the phone. If I send a message via Miranda from Moth to Shade, it says "Delivery failure: No valid OMEMO session exists" ???

I'm going crazy here. I'm no IT Expert and I wanted to spread Jabber, because I really think it's a good messaging system. But the only really userfriendly way to use it up to now is Conversations... IMHO.
And even there the creation of Accounts on other servers sucks... but I guess that's a completely different topic.

Sorry for the confusing post. I'm demotivated. :( Help!
 

Offline dartraiden

  • Localization Maintainer
  • *****
  • Posts: 356
  • Country: ru
  • Karma: 13
  • Jabber ID
  • Version Info
Re: Jabber does not synchronize
« Reply #1 on: 09 08 2018, 19:26:53 »
Is "Message Carbons" enabled in Miranda Jabber settings? "Receive conversations from other devices (XEP-0280)"
_██_
(°ᴗƪ)
 

Offline MothTopic starter

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Re: Jabber does not synchronize
« Reply #2 on: 10 08 2018, 07:47:31 »
Thx for the answer! Yes, that's enabled.

I really, really don't get it. Today I sent another test to Shade from Moth via Miranda. Miranda then asked me, if I wanted to trust the contact and showed me Shades Pix-Art Fingerprint to accept. Now I can write in general, but with this session I have the same problem now. I can send messages from Miranda and recieve answers on both devices, but my own messages I send from Miranda are not displayed in Conversations/Gajim.

The accounts used are on draugr and hot-chilli, so I guess it should not be a compliance problem with the servers. And anyhow the sync works between Gajim and Conversations/Pixart... BUT neither between Gajim and Miranda.  ??? So it's most definetly a problem with my Miranda settings. :-/
I read all possible setting thoroughly, but can't figure out what could be the problem.

 

Offline dartraiden

  • Localization Maintainer
  • *****
  • Posts: 356
  • Country: ru
  • Karma: 13
  • Jabber ID
  • Version Info
Re: Jabber does not synchronize
« Reply #3 on: 10 08 2018, 07:56:36 »
Crashlog with debug symbols will be very helpful
_██_
(°ᴗƪ)
 

Offline dartraiden

  • Localization Maintainer
  • *****
  • Posts: 356
  • Country: ru
  • Karma: 13
  • Jabber ID
  • Version Info
Re: Jabber does not synchronize
« Reply #4 on: 10 08 2018, 07:57:14 »
So it's most definetly a problem with my Miranda settings
Or maybe it's Miranda bug. OMEMO still buggy...
_██_
(°ᴗƪ)
 

Offline MothTopic starter

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
Re: Jabber does not synchronize
« Reply #5 on: 10 08 2018, 08:05:09 »
crash was just a temporary problem... new start fixed this

I guess I'll just sit with gajim until omemo is set in properly ^^'