Author Topic: Problems with proxy support after upgrading to 0.95.8  (Read 399 times)

0 Members and 1 Guest are viewing this topic.

Offline wielorybusTopic starter

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
It looks like I can't connect to GG/jabber through proxy after upgrading to 0.95.8 x64. Anybody has the same issue?

[21:21:54 466C] [GG] mainthread() (1f1d7b0): Connection cannot be established. errno=13: Permission denied

P.S. I'm using HTTPS proxy on 8080 port.
« Last Edit: 08 05 2018, 19:55:53 by wielorybus »
 

Offline Goraf

  • Beta Tester
  • *****
  • Posts: 265
  • Karma: 13
Re: Problems with proxy support after upgrading to 0.95.8
« Reply #1 on: 08 05 2018, 20:08:48 »
I thought that it is only a GG problem and that plugin is messed up, because it seems like it cannot handle proxy+SSL (SSL connection forced in this plugin update). Are you sure you have the same problem with jabber? (it could suggest sth global then)
 

Offline wielorybusTopic starter

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Problems with proxy support after upgrading to 0.95.8
« Reply #2 on: 09 05 2018, 07:04:00 »
I'm not sure about jabber (let me check later today). Is there any way to disable the SSL in GG to check?
 

Offline wielorybusTopic starter

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Problems with proxy support after upgrading to 0.95.8
« Reply #3 on: 09 05 2018, 07:16:11 »
OK, it looks like jabber (Google Talk) is working over the proxy, so the problem is only with the GG protocol.
 

Offline Goraf

  • Beta Tester
  • *****
  • Posts: 265
  • Karma: 13
Re: Problems with proxy support after upgrading to 0.95.8
« Reply #4 on: 09 05 2018, 08:09:25 »
To disable SSL in GG right now, you would have to use DbEditor plugin. After installation, launch it from "Main menu -> Database -> Database Editor++". In the opened window, find in the left panel "folder" with name as internal name of your GG account (probably "GG" with some number) and click it. In the right panel find item with name "SSLConection" double-click it and change its value from 1 to 0. Try to reconnect. It could help but in case it would not then do the same for "ManualHost".
 

Offline wielorybusTopic starter

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Problems with proxy support after upgrading to 0.95.8
« Reply #5 on: 10 05 2018, 10:35:40 »
OK, Setting SSLConnection and ManualHost to 0 helped. But would it be fixed? I'd like to use SSL...