Author Topic: Null pointer in mir_app.mir!CompareProtos  (Read 213 times)

0 Members and 1 Guest are viewing this topic.

Offline peci1Topic starter

  • Newbie
  • *
  • Posts: 10
  • Karma: 0
Null pointer in mir_app.mir!CompareProtos
« on: 30 03 2018, 00:05:44 »
After the last update (I'm on the unstable channel), Miranda crashes right after I start it and enter the decryption password.

Database migration was successful a week ago and I was able to use Miranda after it. This problem occured later.

Debugging in VS, I got this info:

Code: [Select]
> mir_app.mir!CompareProtos(const MBaseProto * p1, const MBaseProto * p2) Line 28 C++ Symbols loaded.
  mir_core.mir!List_GetIndex(SortedList * p_list, void * p_value, int * p_index) Line 139 C++ Symbols loaded.
  mir_core.mir!List_Find(SortedList * p_list, void * p_value) Line 56 C++ Symbols loaded.
  [Inline Frame] mir_app.mir!LIST<MBaseProto>::find(MBaseProto *) Line 228 C++ Symbols loaded.
  mir_app.mir!Proto_GetUniqueId(const char * szModuleName) Line 179 C++ Symbols loaded.
  Actman.dll!000000001710bc38() Unknown No symbols loaded.

Code: [Select]
Exception thrown at 0x00000000128ED80D (mir_app.mir) in Miranda64.exe: 0xC0000005: Access violation reading location 0x0000000000000000. occurred
Unfortunately, the crash is before CrashReporter is initialized, so no useful dumps from it. I took a snapshot in VS, currently I'm uploading it, and I'll post a link when it's ready.

VersionInfo also unavailable due to the early crash. I'm using Win 10 64bit.
 

Offline peci1Topic starter

  • Newbie
  • *
  • Posts: 10
  • Karma: 0
Re: Null pointer in mir_app.mir!CompareProtos
« Reply #1 on: 30 03 2018, 00:14:18 »
The Actman plugin was the problematic one - disabling it helped, Miranda starts normally. For me, it's a viable solution, since I think I didn't use this plugin at all...
 

Offline peci1Topic starter

  • Newbie
  • *
  • Posts: 10
  • Karma: 0
Re: Null pointer in mir_app.mir!CompareProtos
« Reply #2 on: 30 03 2018, 00:20:27 »
Ahh, I again forgot there's the Github for bugreports... Migrated the issue there: https://github.com/miranda-ng/miranda-ng/issues/1231 .

Could admins mention it in the "Forum Rules" sticky post?