Author Topic: Plugin updater & proxy  (Read 2525 times)

0 Members and 1 Guest are viewing this topic.

Offline pepinlebref

  • Jr. Member
  • **
  • Posts: 77
  • Country: fr
  • Thanked: 2 times
  • Pepin le Bref, father of Charlemagne!
Plugin updater & proxy
« on: 16 09 2015, 06:52:51 »
Hi there,
It seems the plugin updater does not use any proxy configured but tries to connect directly.
Is it a known issue of just me?
I start the update manually if it matters...
 

Offline Robyer

Re: Plugin updater & proxy
« Reply #1 on: 28 09 2015, 16:51:37 »
pepinlebref, for me it works correctly (as I used just local proxy from Fiddler, I can see communication going through). Make sure you selected correct PU connection in Options / Network where you set the proxy server. Maybe your settings there are wrong so it fallback to direct connection.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline pepinlebref

  • Jr. Member
  • **
  • Posts: 77
  • Country: fr
  • Thanked: 2 times
  • Pepin le Bref, father of Charlemagne!
Re: Plugin updater & proxy
« Reply #2 on: 29 09 2015, 05:43:28 »
OK, got it!
In fact the option page now shows the checkbox 'use proxy server' fully checked when <All connections> is selected while I think it was a sort of three states check box selected when one or more of the connections has different options...
Something has change in this?
 

Offline Robyer

Re: Plugin updater & proxy
« Reply #3 on: 29 09 2015, 07:29:20 »
pepinlebref, hmm, I remember 3-state checkbox too. Maybe someone accidentally changed this. Please check how it works in stable and report it to tracker / talk about it with with ghazan or other dev.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline Wishmaster

Re: Plugin updater & proxy
« Reply #4 on: 16 11 2015, 22:56:26 »
In fact the option page now shows the checkbox 'use proxy server' fully checked when  is selected while I think it was a sort of three states check box selected when one or more of the connections has different options... Something has change in this?
It should be fixed now :)