Author Topic: Sounds - Incoming Instant Message (not working)  (Read 3557 times)

0 Members and 1 Guest are viewing this topic.

Offline jahTopic starter

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Sounds - Incoming Instant Message (not working)
« on: 01 04 2014, 12:43:50 »
I just did a fresh install of Miranda NG, 64-bit, version 0.94.9 in Windows 7.  I copied my old profile .dat file from a Miranda IM 32-bit unicode installation on XP and ran the DBChecker on it.  I used the installer, not the 7zip package.  The README said sounds are installed with the installer but they weren't so I downloaded the sound pack.  All plugins I installed were done through the Miranda interface so they should all be the appropriate type.  Everything works fine including event sounds with the exception of the instant message incoming sounds (focused and unfocused window).  Those two events don't generate a sound though if I hit the preview button for that event it does generate the expected sound.  I changed a few things around, the sound file, the window manager plugin, etc., but nothing made a difference.  I finally set the sound I wanted for incoming messages to the "stopped typing" event and that seems to give me the same result as if I had set it via the incoming message events.  Is this the expected behavior?  Or is something not working exactly right with my installation?
 

Offline watcher

Re: Sounds - Incoming Instant Message (not working)
« Reply #1 on: 01 04 2014, 13:27:45 »
There is a problem with sounds on current Miranda NG on XP. Use Bass_interface plugin for workaround,
Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline jahTopic starter

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Sounds - Incoming Instant Message (not working)
« Reply #2 on: 01 04 2014, 13:31:20 »
There is a problem with sounds on current Miranda NG on XP. Use Bass_interface plugin for workaround,

I'm using Windows 7 64-bit.  Any issues with sound on that OS?
 

Offline watcher

Re: Sounds - Incoming Instant Message (not working)
« Reply #3 on: 01 04 2014, 13:31:55 »
Not that i'm aware of.

Post Merge: [time]01 04 2014, 15:39:50[/time]
The README said sounds are installed with the installer but they weren't so I downloaded the sound pack.

You should have checked the component.


Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline watcher

Re: Sounds - Incoming Instant Message (not working)
« Reply #4 on: 01 04 2014, 13:34:15 »
Post your Version Info please.
Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline watcher

Re: Sounds - Incoming Instant Message (not working)
« Reply #5 on: 01 04 2014, 13:37:34 »
Anyway - install Bass_interface plugin and see if it solved the problem.

Post Merge: 01 04 2014, 13:39:42
http://wiki.miranda-ng.org/index.php?title=Installation_and_update#Adding_plugins
Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline jahTopic starter

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Sounds - Incoming Instant Message (not working)
« Reply #6 on: 01 04 2014, 13:41:24 »
You should have checked the component.

Whether or not the sound pack was installed by the installer is really beside the point (I think).  I shouldn't have mentioned it.  Just trying to provide as much info as possible.  Too much probably.  Basically I was just wondering why incoming instant messages don't generate a sound.  Since all other sound events seem to work fine it seems more likely to me that it is a bug rather than a configuration issue.  Version info:

I just did a fresh install of Miranda NG, 64-bit, version 0.94.9 in Windows 7.

I'll also try the Bass_interface plugin when I get home this afternoon and see if that makes a difference.
 

Offline watcher

Re: Sounds - Incoming Instant Message (not working)
« Reply #7 on: 01 04 2014, 13:43:05 »
Problem is that typing notify events sounds block the incoming message sound, with bass_interface it shouldn't happen.
Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline jahTopic starter

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
Re: Sounds - Incoming Instant Message (not working)
« Reply #8 on: 01 04 2014, 13:45:43 »
Problem is that typing notify events sounds block the incoming message sound, with bass_interface it shouldn't happen.

Ahh, ok.  I think that answers my question then.  I don't really care much about typing events.  Maybe I can uncheck those to get my incoming messages sounds to work.  Thanks for that information!


Post Merge: 02 04 2014, 11:11:09
After turning off typing sounds, incoming instant message sounds are working now.   It should have occurred to me that one might be blocking the other since the events seem to happen simultaneously.  Anyway, thanks for the info and the info on sound pack installation.  Miranda NG is a very nice improvement.
« Last Edit: 02 04 2014, 11:11:09 by jah »