Author Topic: I can't get my protocols to reconnect automaticaly  (Read 6251 times)

0 Members and 1 Guest are viewing this topic.

Offline WhiplashTopic starter

  • Jr. Member
  • **
  • Posts: 78
  • Karma: 0
As the header says, I can never get my protocols reconnected automatically after disconnection. I found the fallowed options for each IRC server and checked the boxed there:
- Reconnect (checked: Enable, Wait (s) 10, Retry count 1000)
- Rejoin channels on reconnect
- Keep connection alive

But I actually never saw Miranda NG reconnecting automatically. When I come back to my PC, none of the statuses is on. So, I always have to chose "Online" manually. Is there some other thing that I missed maybe?
 

Offline watcher

Re: I can't get my protocols to reconnect automaticaly
« Reply #1 on: 23 11 2013, 18:08:20 »
You need plugin named KeepStatus - there is no reconnection function built in core, well there is some, but very basic
Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline WhiplashTopic starter

  • Jr. Member
  • **
  • Posts: 78
  • Karma: 0
Re: I can't get my protocols to reconnect automaticaly
« Reply #2 on: 23 11 2013, 18:28:56 »
Ah, thanks. Maybe Miranda NG could include this one as default one in installation package since it's very important.
 

Offline WhiplashTopic starter

  • Jr. Member
  • **
  • Posts: 78
  • Karma: 0
Re: I can't get my protocols to reconnect automaticaly
« Reply #3 on: 24 11 2013, 19:59:20 »
Damn, I didn't tested the plugin until now. Now I see that it doesn't work either. Actually, it works only for MSN account. None of my IRC accounts are reconnected by this automatically.
I would like if someone could test it too.
« Last Edit: 04 12 2013, 21:24:21 by Whiplash »
 

Offline White-Tiger

  • Developer
  • *****
  • Posts: 182
  • Country: 00
  • Karma: 10
  • SendSS maintainer
Re: I can't get my protocols to reconnect automaticaly
« Reply #4 on: 24 11 2013, 20:47:24 »
Options->Status->KeepStatus

Make sure all protocols you want to reconnect are checked ;)
Also setup everything else you need.. eg. max retries, delay etc.

 

Offline WhiplashTopic starter

  • Jr. Member
  • **
  • Posts: 78
  • Karma: 0
Re: I can't get my protocols to reconnect automaticaly
« Reply #5 on: 24 11 2013, 22:48:31 »
Options->Status->KeepStatus

Make sure all protocols you want to reconnect are checked ;)
Also setup everything else you need.. eg. max retries, delay etc.
I did that already, and it didn't work. But I found the reason. Reconnecting shouldn't be enabled (checked) in options of each account (example: options, DalNet: "Reconnect" - unchecked, "Rejoin channels on reconnect" - unchecked). Seems it's in some collision with the KeepStatus's options. After I unchecked it for all of the accounts - it worked finally as it should. I'm not sure if it can be threated as a bug. Good thing is that these things are unchecked in each IRC account by default, so most of the people will not experience it.
« Last Edit: 04 12 2013, 21:17:16 by Whiplash »
 

Offline White-Tiger

  • Developer
  • *****
  • Posts: 182
  • Country: 00
  • Karma: 10
  • SendSS maintainer
Re: I can't get my protocols to reconnect automaticaly
« Reply #6 on: 24 11 2013, 23:11:29 »
but good to know... as if this really happens, there should be at least a compatibility fix inside IRC or KeepStatus... (probably IRC)