Author Topic: Problem with ICQ after update  (Read 523 times)

0 Members and 1 Guest are viewing this topic.

Offline the Dark Lord

  • Newbie
  • *
  • Posts: 28
Problem with ICQ after update
« on: 14 09 2022, 17:50:05 »
I recently updated my Miranda and the ICQ stopped working. It refuses to connect me (something about unknown error) and I have no idea what happened.
Anybody have any idea how to make it work again?

VersionInfo
Quote
CPU: 11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz [Intel64 Family 6 Model 140 Stepping 1] [DEP Enabled] [8 CPUs]
Installed RAM: 16168 MBytes
Microsoft Windows 10 , 64-bit (build 22000)
Internet Explorer: 9.11.22000.0 (build 922000)
Administrator privileges: No
OS Languages: (UI | Locale (User/System)) : Czech/Czech | Czech/Czech
Free disk space on Miranda partition: 304312 MBytes

Miranda NG Version: 0.96.2 alpha build #24853 (64085fa4e5) [running inside WOW64]
Build time: 14 Sep 2022 2:20:38
Profile: C:\Users\Diel\Desktop\MIRANDA NEW\Profile\ELI\ELI.dat
Database driver: SQLite database driver
Profile size: 4050944 Bytes
Profile creation date: 14 Sep 2022 19:43:34
Language pack: Czech (CZ) [0405]
Service Mode: No

Active Plugins (22):
¤ AVS.dll v.0.98.1.5 [14 Sep 2022 2:20:46] - Avatar service
¤ Contacts.dll v.1.6.0.0 [14 Sep 2022 2:21:06] - Send/receive contacts
¤ CrashDumper.dll v.0.2.0.1 [14 Sep 2022 2:22:34] - Crash dumper
¤ Db_autobackups.dll v.0.1.0.7 [14 Sep 2022 2:21:12] - Db autobackuper
¤ DbChecker.dll v.0.95.13.3 [14 Sep 2022 2:25:04] - Database checker
¤ DbEditorPP.dll v.4.1.0.2 [14 Sep 2022 2:22:30] - Database editor++
¤ Dbx_mdbx.dll v.0.95.9.1 [14 Sep 2022 2:25:04] - Miranda NG MDBX database driver
¤ Dbx_mmap.dll v.0.95.8.1 [14 Sep 2022 2:20:44] - Miranda NG mmap database driver
¤ Dbx_sqlite.dll v.0.96.1.2 [14 Sep 2022 2:24:54] - Miranda NG SQLite database driver
¤ Dummy.dll v.0.2.0.1 [14 Sep 2022 2:24:12] - Dummy protocol
¤ Folders.dll v.0.2.0.2 [14 Sep 2022 2:21:12] - Custom profile folders
¤ historypp.dll v.1.5.1.5 [14 Sep 2022 2:25:30] - History++
¤ ICQ.dll v.0.96.2.1 [14 Sep 2022 2:25:04] - ICQ-WIM protocol
¤ Import.dll v.0.95.11.1 [14 Sep 2022 2:21:10] - Import contacts and messages
¤ MenuEx.dll v.1.3.2.0 [14 Sep 2022 2:21:16] - Menu item ext
¤ NewXstatusNotify.dll v.1.4.0.12 [14 Sep 2022 2:21:24] - xStatus notify
¤ PluginUpdater.dll v.0.2.1.3 [14 Sep 2022 2:22:40] - Plugin updater
¤ SkypeWeb.dll v.0.95.13.3 [14 Sep 2022 2:24:26] - Skype protocol (Web)
¤ SmileyAdd.dll v.0.3.2.2 [14 Sep 2022 2:21:40] - SmileyAdd
¤ SplashScreen.dll v.0.1.2.3 [14 Sep 2022 2:21:26] - Splash screen
¤ Variables.dll v.0.2.3.12 [14 Sep 2022 2:21:40] - Variables
¤ WhenWasIt.dll v.0.4.0.1 [14 Sep 2022 2:21:30] - Birthday reminder

Unloadable Plugins (5):
¤ NewStatusNotifyW.dll v.0.0.0.0 [19 Jul 2006 9:39:38] - <unknown>

¤ Popup.dll v.0.0.0.0 [28 Dec 2018 22:20:14] - <unknown>
    Plugin statically linked to missing module: mir_core.mir
    Plugin statically linked to missing module: mir_app.mir
    Plugin statically linked to missing module: api-ms-win-crt-string-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-time-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-heap-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-runtime-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-stdio-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-filesystem-l1-1-0.dll

¤ startup_sound.dll v.0.0.0.0 [11 Dec 2003 8:01:22] - <unknown>

¤ TabSRMM.dll v.0.0.0.0 [28 Dec 2018 22:20:08] - <unknown>
    Plugin statically linked to missing module: FreeImage.mir
    Plugin statically linked to missing module: mir_core.mir
    Plugin statically linked to missing module: mir_app.mir
    Plugin statically linked to missing module: api-ms-win-crt-convert-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-string-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-time-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-heap-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-locale-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-stdio-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-filesystem-l1-1-0.dll
    Plugin statically linked to missing module: api-ms-win-crt-runtime-l1-1-0.dll

¤ uptime.dll v.0.0.0.0 [3 Jul 2005 2:41:12] - <unknown>


Protocols and Accounts:
-------------------------------------------------------------------------------
ICQ                      1 - Enabled 0 - Disabled  Loaded

Icon Packs:
-------------------------------------------------------------------------------
 desktop.ini [31 Dec 2013 2:43:32]
 DISCORD-0.png [29 Dec 2018 18:59:18]
 DISCORD-1.png [29 Dec 2018 18:58:40]
 HistoryPP_icons.dll [14 Sep 2022 2:25:14]
 main-icons.dll [16 Nov 2006 9:43:32]
 MIRANDA.EXE [11 Feb 2006 9:34:22]
 NOAVATAR.GIF [8 Mar 2006 9:35:16]
 proto_conn_facebook.dll [5 Mar 2011 20:37:52]
 Proto_Dummy.dll [14 Sep 2022 2:25:18]
 Proto_ICQ.dll [16 Nov 2004 9:11:32]
 Proto_MetaContacts.dll [14 Sep 2022 2:25:18]
 Proto_MRA.dll [14 Sep 2022 2:25:20]
 Proto_Skype.dll [14 Sep 2022 2:25:18]
 SecureIM_icons.dll [14 Sep 2022 2:25:12]
 SKP00.ico [25 May 2014 16:09:28]
 SKP01.ico [25 May 2014 16:10:28]
 SKP02.ico [25 May 2014 16:14:02]
 SKP03.ico [25 May 2014 16:11:22]
 SKP04.ico [25 May 2014 16:11:56]
 SKP05.ico [25 May 2014 16:12:16]
 SKP06.ico [25 May 2014 16:12:40]
 TabSRMM_icons.dll [14 Sep 2022 2:25:14]
 Thumbs.db [26 Feb 2012 18:00:42]
 Toolbar_icons.dll [14 Sep 2022 2:25:12]
 UInfoEx_icons.dll [14 Sep 2022 2:25:12]
 xstatus_icons.dll [16 Dec 2006 9:44:32]
 xStatus_ICQ.dll [7 Aug 2006 9:40:14]
[close]
 

Offline dartraiden

Re: Problem with ICQ after update
« Reply #1 on: 14 09 2022, 20:48:08 »
Please provide netlog of ICQ protocol.
 

Offline the Dark Lord

  • Newbie
  • *
  • Posts: 28
Re: Problem with ICQ after update
« Reply #2 on: 19 09 2022, 16:24:39 »
It seems to have a problem with login, but I changed nothing about that, I just upgraded Miranda via updater plugin.
I have a copy of the original version of Miranda, which doesn't help either, I tried to do the upgrade again, with no success.
The old Miranda doesn't log in either (which was the reason I upgraded it, although few days ago it worked), but the old one doesn't show any error message, it just stays offline.


Here is the log of upgraded Miranda:
[2022-09-19 18:24:09 CF74] [ICQ_1] CIcqProto::SetStatus iNewStatus = 40072, m_iStatus = 40071, m_iDesiredStatus = 40071 m_hWorkerThread = 00000678
[2022-09-19 18:24:09 CC70] [ICQ_1] Executing request 9c80890c-1500-424d-b380-f1eccee64d5f:
https://api.login.icq.net/auth/clientLogin
[2022-09-19 18:24:09 CC70] [ICQ_1] Connection request to api.login.icq.net:443 (Flags 11)....
[2022-09-19 18:24:09 CC70] [ICQ_1] (07298490) Connecting to server api.login.icq.net:443....
[2022-09-19 18:24:09 CC70] [ICQ_1] (07298490) Connecting to ip 178.237.20.78:443 ....
[2022-09-19 18:24:09 CC70] [ICQ_1] (2152) Connected to api.login.icq.net:443
[2022-09-19 18:24:09 CC70] [ICQ_1] (2152 api.login.icq.net) Starting SSL/TLS negotiation
[2022-09-19 18:24:09 CC70] [ICQ_1] (2152 api.login.icq.net) SSL/TLS negotiation successful
[2022-09-19 18:24:10 CC70] [ICQ_1] (07298490:2152) Data received
HTTP/1.1 200 OK
Server: openresty
Date: Mon, 19 Sep 2022 16:24:10 GMT
Content-Type: application/json;charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
Keep-Alive: timeout=75
Vary: Accept-Encoding
Pragma: no-cache
Cache-Control: no-store,no-cache,must-revalidate
Strict-Transport-Security: max-age=31536000; includeSubDomains; preload
Content-Encoding: gzip

a9
‹
{"response":{"statusCode":330, "statusText":"Password/LoginId Required/Invalid", "statusDetailCode":3011, "data":{"challenge":{"context":"VtmMeQAAAFkAAh50", "info":"Enter your password again"}}}}
[2022-09-19 18:24:10 CC70] [ICQ_1] ConnectionFailed -> reason 1
[2022-09-19 18:24:10 CC70] [ICQ_1] CIcqProto::ShutdownSession
[2022-09-19 18:24:10 CC70] [ICQ_1] CIcqProto::OnLoggedOut
« Last Edit: 19 09 2022, 16:35:50 by the Dark Lord »
 

Offline dartraiden

Re: Problem with ICQ after update
« Reply #3 on: 19 09 2022, 16:40:06 »
If you upgraded from version 0.95.4 or older, see our wiki.
 

Offline the Dark Lord

  • Newbie
  • *
  • Posts: 28
Re: Problem with ICQ after update
« Reply #4 on: 19 09 2022, 16:57:42 »
I upgradede from:
Miranda NG Version: 0.95.11 alpha build #21101 (55e240d0dd) [running inside WOW64]
Build time: 28 Dec 2018 22:19:58


I followed the description on the wiki, but there isn't "more-than-8-symbols-password", there is only 8 characters.
I checked the old Miranda and the upgraded Miranda just to be sure, in both cases the password line contains exactly 8 characters.
 

Offline the Dark Lord

  • Newbie
  • *
  • Posts: 28
Re: Problem with ICQ after update
« Reply #5 on: 19 09 2022, 17:08:03 »
OK, I made it working.
The upgraded Miranda replaced the UIN number in login by email.
I reentered the UIN and retyped the password and suddenly it works.

The troubleshooting link you posted me was about too long passwords, but mine wasn't, mine was exactly 8 symbols.
Maybe the problem was with the change of login from UIN number to e-mail? I still don't know why this change happened.

Thanks for all the support.
It really helped to check the login info more closely.
 

Offline dartraiden

Re: Problem with ICQ after update
« Reply #6 on: 19 09 2022, 17:20:09 »
I have absolutely no idea where the mail could come from since we not retrieve e-mail from server

« Last Edit: 19 09 2022, 19:01:44 by dartraiden »
 

Offline the Dark Lord

  • Newbie
  • *
  • Posts: 28
Re: Problem with ICQ after update
« Reply #7 on: 19 09 2022, 17:36:15 »
Me neither. I didn't change a thing about login during the upgrade, I just let the upgrade to do its own job. The updater plugin did it all. When it restarted itself after the upgrade, it posted me that unknown error pop-up. I tried to restore old Miranda and do the upgrade again (for case something went wrong during the upgrad) with the same results.
But when I was comparing the login settings in the old Miranda and upgraded Miranda (as the troubleshooting link suggested there might be something wrong with the login), there it was instead of UIN.

Despite the problem was different, your help pointed me the right direction to make it work again  :)
« Last Edit: 19 09 2022, 17:38:32 by the Dark Lord »