Author Topic: GG protocol do not working  (Read 520 times)

0 Members and 1 Guest are viewing this topic.

Offline zuku

  • Newbie
  • *
  • Posts: 22
  • Country: 00
  • Jabber: Jabber ID
GG protocol do not working
« on: 14 09 2022, 13:39:06 »
Hi,
I have such problem since a few days, GG account login does not work.
I have tried with multiple computers and separate networks, the same problem exist.
When login using web GG page then all accounts are working.
 

Offline dartraiden

Re: GG protocol do not working
« Reply #1 on: 14 09 2022, 20:46:52 »
Server certificate is expired. It's not our problem.

You can disable SSL cert validation in Miranda network options.
 

Offline zuku

  • Newbie
  • *
  • Posts: 22
  • Country: 00
  • Jabber: Jabber ID
Re: GG protocol do not working
« Reply #2 on: 15 09 2022, 18:02:45 »
I have changed gg servers as recommended in Polish subboard - and now my gg is connecting, when will you release new mirange with updated gg servers?
 

Offline dartraiden

Re: GG protocol do not working
« Reply #3 on: 15 09 2022, 19:29:03 »
Using an IP instead of domain is not a good idea, because the IP address of a domain can change at any time. This is good as a temporary hack until the GG renews the certificates.

So we won't use this in Miranda by default. I believe that in the foreseeable future the certificates will be updated. Up to this point, users are free to use the IP address workaround.
 

Offline dartraiden

Re: GG protocol do not working
« Reply #4 on: 20 09 2022, 21:44:40 »
Fixed in both stable and dev versions. Please remove custom servers from protocol options.
« Last Edit: 20 09 2022, 21:52:58 by dartraiden »
 

Offline fakuś

Re: GG protocol do not working
« Reply #5 on: 07 10 2022, 06:35:27 »
Hi.
I am looking for a solution to the problem with the GG plug and of course I found myself on the Miranda forum;)
In my case, for several days there is also a problem with logging in to the GG servers.
Logging in works via the website - not possible from the "Miranda" level :(
I deleted the list of IP addresses from the "Protocols / GG / Advanced" tab, but to no avail. Still doesn't connect.
The "Enter server addresses" and "Use encrypted SSL connection" options are checked but inactive. And they do not become active even when the IP address field is entered.

GG plug version: 0.95.11.1
Miranda: 0.96.2


« Last Edit: 07 10 2022, 06:37:25 by fakuś »
 

Offline ghazan

Re: GG protocol do not working
« Reply #6 on: 07 10 2022, 13:14:57 »
fakuś,
dunno how it happens, could you try to manually remove GG_1/ServerHosts key from dbeditor -> Settings?
 
The following users thanked this post: fakuś

Offline fakuś

Re: GG protocol do not working
« Reply #7 on: 07 10 2022, 16:26:14 »
I deleted the key you gave and .... BINGO - after restart Miranda logged into "GG" :)
By the way, these checkboxes are still greyed out and inaccessible, and the IP address has appeared on the list of addresses, which I removed earlier because Miranda was not logging in :)

The bottom line is that your help has been successful - thank you very much.

greetings
 
The following users thanked this post: ghazan, qsatis

Offline ghazan

Re: GG protocol do not working
« Reply #8 on: 07 10 2022, 16:32:49 »
fakuś,
well, Miranda resets IP list if it is missing, the problem is that empty list isn't treated as missing, it exists but it's empty
so it didn't surprise me that key removal helped, perhaps the check for emptiness should be changed somehow...
 
The following users thanked this post: qsatis, fakuś

Offline dartraiden

 
The following users thanked this post: fakuś