Author Topic: "Send message" hotkey has stopped working  (Read 789 times)

0 Members and 1 Guest are viewing this topic.

Offline dartraiden

"Send message" hotkey has stopped working
« on: 29 03 2022, 14:47:52 »
If sending messages using a hotkey (Ctrl+Enter, etc.) has stopped working, you should set the desired combination in the CustomizeHotkeysSend message.
« Last Edit: 30 03 2022, 16:55:38 by dartraiden »
 

Offline weblurker

  • Newbie
  • *
  • Posts: 11
Re: "Send message" hotkey has stopped working
« Reply #1 on: 03 06 2022, 20:24:23 »
I had set the Send Message hotkey to Alt+S, which worked for years.
With the new update, Alt+S no longer works.
I tried cntrl+Enter, cntrl+Z, alt+shift+S and none of those worked either.

I changed the Send Message hotkey to <Enter> and that worked.

I then entered two bindings, Alt+S and Enter. Enter sends a message but Alt+S doesn't.

What's odd is that if I remove <Enter> and go back to just Alt+S, hitting Enter still sends a message, but Alt+S doesn't work.

I have a friend that I use Miranda to communicate with. What really odd is that the display he sees for Customizing Hotkeys -> Messaging only shows "Send Message"

The display I see has a lot of hotkeys that can be customized under 3 sections, "Message windows - IM", "Message windows - all" and "Message windows - group chats"

At the moment, the only way I can send a message is by hitting the Enter key, even though Alt+S is the hotkey for Send Message.

Also, my friend and I used to use ICQ and then switched to Jabber. The ICQ history was lost during the database conversion but the Jabber history was retained.

Edit: Cntrl+Enter now works to send a message. I'm not exactly sure what I did. I did uncheck the "Send Message" hotkey box and then checked it. Maybe that toggled something.
« Last Edit: 03 06 2022, 20:30:52 by weblurker »
 

Offline dartraiden

Re: "Send message" hotkey has stopped working
« Reply #2 on: 03 06 2022, 20:59:50 »
Quote
I have a friend that I use Miranda to communicate with. What really odd is that the display he sees for Customizing Hotkeys -> Messaging only shows "Send Message"

The display I see has a lot of hotkeys that can be customized under 3 sections, "Message windows - IM", "Message windows - all" and "Message windows - group chats

You are probably using tabSRMM and your friend is using a different messaging plugin (StdMsg or Scriver).

Quote
With the new update, Alt+S no longer works.
Confirmed
https://github.com/miranda-ng/miranda-ng/issues/3090

For example, in StdMsg Alt+S is internal (hardcoded) hotkey for "Show/hide nicklist in chat", so you cannot bind it to "Send message" (you can try but it will behave unpredictably - it will randomly do one of two things). Maybe tabSRMM also has such hotkey (and the fact that it worked before the update for message sending is a bug), dunno.

This discussion made me think that it's time for us to get rid of hardcoded hotkeys, making them all customizable

Quote
The ICQ history was lost during the database conversion
I can partially reproduce these issue, so we will investigate it
https://github.com/miranda-ng/miranda-ng/issues/3089
« Last Edit: 03 06 2022, 21:13:48 by dartraiden »
 

Offline weblurker

  • Newbie
  • *
  • Posts: 11
Re: "Send message" hotkey has stopped working
« Reply #3 on: 03 06 2022, 21:46:36 »
Thanks for the reply.

You were correct, tabSRMM is installed. I'll find out from my friend what he's running and replicate his setup.

At the moment, typing Alt+S results in a beep but nothing else seems to happen.

It turns out my friend isn't running StdMsg or Scriver.

If I disable tabSRMM by unchecking the box in the plugins section, will that cause Miranda to default to the simpler Hotkey interface?
 

Offline dartraiden

Re: "Send message" hotkey has stopped working
« Reply #4 on: 03 06 2022, 22:38:40 »
This will cause Miranda to switch to StdMsg - completely different message plugin with simple message window, simple hotkeys, etc.
 

Offline dartraiden

Re: "Send message" hotkey has stopped working
« Reply #5 on: 05 06 2022, 17:45:57 »
"Alt+S" should be fixed in today's stable version update.
 

Offline weblurker

  • Newbie
  • *
  • Posts: 11
Re: "Send message" hotkey has stopped working
« Reply #6 on: 06 06 2022, 23:43:35 »
Yes, alt-S works now. Thanks.