Author Topic: Skype keeps disconnecting  (Read 986 times)

0 Members and 1 Guest are viewing this topic.

Offline Ratha

Re: Skype keeps disconnecting
« Reply #15 on: 29 03 2020, 22:49:22 »
Just to add my two cents to the current issues with Skype:
- I am still getting disconnected constantly. (At least 5-10 times an hour) The issue started around March 27th, but not sure of the exact date or time. (And also impacted a version of Miranda from early 2019)
- Most of my Skype contacts do not show up as online anymore. Can confirm they are online by visiting web.skype.com (A couple of contacts do show as online though.)
- Messages are not reliably being received. Can log into the website and retrieve them, but Miranda will not retrieve them no matter how many times I try going offline, waiting, and logging back in.
- EDIT: I am no longer receiving "offline" messages. I intentionally set myself to offline, waited 1-2 minutes, had a friend send me 3 messages. Waited 1-2 minutes, logged on, and no messages were downloaded.
- If you use the "Get Skype Server History" option to retrieve those missing messages, it will fill your history with hundreds or thousands of duplicate messages. (Not sure if its possible to automatically remove them. May have to see how far back the server history goes, delete all your local history for that range, and then import the history from the server to avoid duplicate entries.)

EDIT2: It seems that Miranda does not update 'message read' status for the official client either. (Not sure if it ever did, but just in case its related to some of  the problems going on, heres an event chain:)
- Logged in and then out of web.skype.com
- Logged out of Skype in Miranda
- Friend sent 3 messages using official Skype client while I was offline.
- Logged into Skype in Miranda, did not receive any of the 3 messages.
- Friend sent new message while i was online. Message was received.
- I replied to message received, friend got the message.
- Last read status indicates that i still have not read the 3 messages that were sent when offline. (Or any messages since logging into web.skype.com)

EDIT3: Miranda does not appear to send Skype statuses to the server either. Logged in with "Away" status and friend says I show up only as "Online" in the official client. He indicated that my status message was displayed however.

VersionInfo
CPU: Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz [Intel64 Family 6 Model 60 Stepping 3] [DEP Enabled] [4 CPUs]
Installed RAM: 24521 MBytes
Microsoft Windows 7 Ultimate Edition, 64-bit Service Pack 1 (build 7601)
Internet Explorer: 9.11.9600.18665 (build 99600)
Administrator privileges: Yes
OS Languages: (UI | Locale (User/System)) : English/English | English/English
Free disk space on Miranda partition: 43168 MBytes

Miranda NG Version: 0.95.12 alpha build #22710 (c3284222ed) [running inside WOW64]
Build time: 27 Mar 2020 2:00:42
Profile: C:\Program Files (x86)\Miranda NG\Profiles\Ratha\Ratha.dat
Profile size: 169869312 Bytes
Profile creation date: 24 Nov 2019 11:46:36
Language pack: No language pack installed
Service Mode: No

Active Plugins (20):
¤ AVS.dll v.0.98.1.2 [27 Mar 2020 2:00:48] - Avatar service
¤ CrashDumper.dll v.0.1.0.4 [27 Mar 2020 2:01:16] - Crash dumper
¤ Db_autobackups.dll v.0.1.0.4 [27 Mar 2020 2:00:54] - Db autobackuper
¤ DbEditorPP.dll v.4.0.1.3 [27 Mar 2020 2:01:16] - Database editor++
¤ Dbx_mdbx.dll v.0.95.9.1 [27 Mar 2020 2:02:14] - Miranda NG MDBX database driver
¤ Dbx_mmap.dll v.0.95.8.1 [27 Mar 2020 2:00:46] - Miranda NG mmap database driver
¤ Discord.dll v.0.6.2.5 [27 Mar 2020 2:01:54] - Discord protocol
¤ Dummy.dll v.0.2.0.0 [27 Mar 2020 2:01:46] - Dummy protocol
¤ historypp.dll v.1.5.1.5 [27 Mar 2020 2:02:30] - History++
¤ ICQ.dll v.0.95.11.9 [27 Mar 2020 2:02:02] - ICQ-WIM protocol
¤ Import.dll v.0.95.11.1 [27 Mar 2020 2:01:10] - Import contacts and messages
¤ PluginUpdater.dll v.0.2.0.6 [27 Mar 2020 2:01:18] - Plugin updater
¤ SeenPlugin.dll v.5.0.5.5 [27 Mar 2020 2:01:00] - Last seen
¤ SkypeWeb.dll v.0.12.3.6 [27 Mar 2020 2:02:00] - Skype protocol (Web)
¤ SpellChecker.dll v.0.2.6.6 [27 Mar 2020 2:01:46] - Spell checker
¤ StatusManager.dll v.1.2.0.6 [27 Mar 2020 2:01:54] - Status manager
¤ Steam.dll v.0.11.6.7 [27 Mar 2020 2:01:54] - Steam protocol
¤ TabSRMM.dll v.3.6.1.2 [27 Mar 2020 2:00:56] - TabSRMM
¤ Tipper.dll v.2.1.0.7 [27 Mar 2020 2:01:06] - Tipper
¤ YAMN.dll v.0.1.2.6 [27 Mar 2020 2:01:26] - Mail Notifier

Protocols and Accounts:
-------------------------------------------------------------------------------
Discord                  2 - Enabled 0 - Disabled  Loaded
ICQ                      1 - Enabled 1 - Disabled  Loaded
SKYPE                    1 - Enabled 0 - Disabled  Loaded
STEAM                    1 - Enabled 0 - Disabled  Loaded

Icon Packs:
-------------------------------------------------------------------------------
 Flags_icons.dll [27 Mar 2020 2:02:24]
 HistoryPP_icons.dll [27 Mar 2020 2:02:24]
 Proto_Discord.dll [27 Mar 2020 2:02:24]
 Proto_Dummy.dll [27 Mar 2020 2:02:24]
 Proto_ICQ.dll [2 Jan 2019 14:26:42]
 Proto_MetaContacts.dll [27 Mar 2020 2:02:24]
 Proto_MRA.dll [27 Mar 2020 2:02:24]
 Proto_Skype.dll [27 Mar 2020 2:02:24]
 Proto_Steam.dll [27 Mar 2020 2:02:24]
 Proto_Yahoo.dll [13 Feb 2016 22:01:38]
 Proto_YAMN.dll [27 Mar 2020 2:02:24]
 TabSRMM_icons.dll [27 Mar 2020 2:02:24]
 xStatus_ICQ.dll [28 Dec 2018 3:02:08]
« Last Edit: 30 03 2020, 00:05:00 by Ratha »
 

Offline dartraiden

Re: Skype keeps disconnecting
« Reply #16 on: 30 03 2020, 13:19:23 »
Another attempt to fix. Try build 22715 or newer.
_██_
(°ᴗƪ)
 

Offline ablazhov

Re: Skype keeps disconnecting
« Reply #17 on: 30 03 2020, 16:30:52 »
Another attempt to fix. Try build 22715 or newer.

Confirmed, the fix works for me!
Miranda 0.95.12 alpha build 22715, SkypeWeb plugin build 0.12.3.6

Can we know what was changed? Just curious.
 

Offline dartraiden

_██_
(°ᴗƪ)
 

Offline SirNassoTopic starter

  • Newbie
  • *
  • Posts: 26
  • Karma: 0
Re: Skype keeps disconnecting
« Reply #19 on: 01 04 2020, 12:38:10 »
Updated to version 22729 and now it seems to have stopped disconnecting.But still the contact list shows noone as online.Although now it seems the messages are recieved.
 

Offline ablazhov

Odp: Skype keeps disconnecting
« Reply #20 on: 02 04 2020, 06:22:41 »
But still the contact list shows noone as online.Although now it seems the messages are recieved.

Same here.
Thread continues here:
https://forum.miranda-ng.org/index.php?topic=4018.msg26564#msg26564

EDIT:
An issue has been opened here:
https://github.com/miranda-ng/miranda-ng/issues/2306
« Last Edit: 06 04 2020, 04:48:28 by ablazhov »
 
The following users thanked this post: SirNasso

Offline TekWiz

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
Re: Skype keeps disconnecting
« Reply #21 on: 25 07 2020, 08:02:14 »
My Skype keeps on disconnecting randomly,and doesn't reconnect automaticaly.Have to constantly go and change it to Online manualy.Tried disabling the auto away status change but nothing changed.So what can you advise me to do?Updated Miranda severel times via autoupdate,and iy's all the same.Currently I'm using 0.95.12 alpha build #22706.

My Skype keeps on disconnecting randomly,and doesn't reconnect automaticaly.Have to constantly go and change it to Online manualy.Tried disabling the auto away status change but nothing changed.So what can you advise me to do?Updated Miranda severel times via autoupdate,and iy's all the same.Currently I'm using 0.95.12 alpha build #22706.

I was having the same problem and it got really bad yesterday. I was using the Keep Status plugin as well but it wasn't helping. The problem was also occurring on a friend's PC. I tried various options in Keep Status but nothing seemed to improve things. After reading this thread, one of the posts mentioned this: "You could easily set Keep status plugin to reconnect after 1 second, not react on login errors and disable exponential delay. This way Miranda will reconnect almost immediately and you will barely notice the disconnections."

So I tried this as well but all it did was make a lot more popups appear in quick succession saying that it seems there is no internet connection but of course there is!!! So finally I changed setting yet again, somehow looks like I got it right!!! Now Miranda has been online for 24 hours and I haven't had to reconnect manually even once, and it always seems online, except I guess when it reconnects but it's so fast I don't notice it... Here are the MAGIC SETTINGS that fixed the problem, I will post screenshots too.

Basic tab:
General: Uncheck Show popups
Account connection: Check connection, Maximum retries 0 (infinite), Delay between retries (secs) 1
Dial-up: Uncheck Don't reconnect if no internet connection seems available
Check Continuously check for internet connection
Do so by pinging host: google.com

Advanced tab:
Uncheck increase delay exponential
Maximum delay (secs) left it at 900
Maximum account connecting time (secs) 1

Reconnecting
Uncheck all of those

Dial-up
Consider connection lost after 1 failed pings
Continuously check interval (secs) 10

That's it. I don't know if all those options are helpful or needed but it does stay online like that... (No I don't have dialup, I have broadband lol)

Hope this is helpful and solves the issue!

Good luck!

EDIT: Today I noticed that while Miranda was online, I wasn't receiving any messages, so I had to select offline and online again to be able to communicate. So I think that in the Keep Status settings, it's good to select the "Set account offline before a reconnection attempt" in the Advanced tab. I guess selecting "Ignore locked status of accounts" and "React on login errors" set for 60 seconds should be fine too.
« Last Edit: 26 07 2020, 20:10:25 by TekWiz »