Author Topic: Важное объявление для пользователей Windows XP  (Read 594 times)

0 Members and 1 Guest are viewing this topic.

Offline dartraidenTopic starter

После обновления TLS-сертификата, используемого сервером, пользователи Windows XP лишились возможности проверять обновления с помощью PluginUpdater.

Выполните следующие шаги:
  • переключитесь на «Заданную пользователем версию» в настройках обновлений (Настройки → Службы → Обновление плагинов)
  • вручную замените https на http
  • примените изменения и запустите проверку обновлений (Главное меню → Проверить обновления)
  • обновите Миранду и переключитесь обратно на желаемую версию (Настройки → Службы → Обновление плагинов)
  • (Важно) не включайте настройку «Использовать HTTPS»
« Last Edit: 20 09 2019, 17:17:36 by dartraiden »
_██_
(°ᴗƪ)
 

Offline MisterMyth

  • Hero Member
  • *****
  • Posts: 512
  • Country: ru
  • Thanked: 9 times
  • Karma: 3
  • Myth: Make Your Thought Heard
  • Version Info
dartraiden, вопрос: а нельзя разве в код добавить проверку на версию ОС? и автоматом заменить адрес и настройку?
Myth: Make Your Thought Heard
 

Offline dartraidenTopic starter

Хорошая мысль. Да, надо по умолчанию эту настройку отключать, если работаем в XP. Таким образом, п.5 уже будет не нужен. Да и новым пользователям будет проще.

Но первые 4 пукнта останутся, потому что существующим пользователям нужно получить новый апдейтер, умеющий работать по HTTP, а старый апдейтер без вмешательства пользователя соединиться не в силах.
« Last Edit: 19 09 2019, 17:03:42 by dartraiden »
_██_
(°ᴗƪ)
 

Offline MisterMyth

  • Hero Member
  • *****
  • Posts: 512
  • Country: ru
  • Thanked: 9 times
  • Karma: 3
  • Myth: Make Your Thought Heard
  • Version Info
dartraiden, ну это понятно.
Myth: Make Your Thought Heard