Author Topic: Discord Not Connecting  (Read 282 times)

0 Members and 1 Guest are viewing this topic.

Offline johndoeTopic starter

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
Discord Not Connecting
« on: 19 02 2019, 19:16:06 »
I do not exactly know when this started as I don't really keep discord online all the time but I haven't been able to get online for quite some time now ( 1-2 days I think at the very least )
I am able to use the discord app without any major issues

I forgot what I needed to attach etc..or where the logs were can someone help me. Is this a known issue or ? is it just me

edit1:also another problem I am having is one of my friends invited me to a private group chat ( not a channel ) just a group chat with some other friends
and ever since that day any message that is posted in the group chat comes as if it was a private msg from him ( even when its other people writing it )
and I can not message him directly either any msg I send to him via miranda goes to that group chat
But all this does not matter atm because the discord isn't working for a while now

VersionInfo
Quote (selected)
CPU: Intel(R) Core(TM) i3 CPU 560 @ 3.33GHz [Intel64 Family 6 Model 37 Stepping 5] [DEP Enabled] [4 CPUs]
Installed RAM: 8120 MBytes
Microsoft Windows 10 Professional Edition, 64-bit (build 17763)
Internet Explorer: 9.11.17763.0 (build 917763)
Administrator privileges: No
OS Languages: (UI | Locale (User/System)) : English/English | English/English
Free disk space on Miranda partition: 243826 MBytes

Miranda NG Version: 0.95.11 alpha build #21416 (7d75ffb5f4) x64
Build time: 18 Feb 2019 2:03:52
Profile:
Profile size: 4657152 Bytes
Profile creation date: 16 Feb 2018 12:20:11
Language pack: No language pack installed
Service Mode: No

Active Plugins (15):
¤ CrashDumper.dll v.0.1.0.3 [10 Feb 2019 13:33:08] - Crash dumper
¤ Db_autobackups.dll v.0.1.0.2 [18 Feb 2019 2:04:06] - Db autobackuper
¤ Dbx_mdbx.dll v.0.95.9.1 [18 Feb 2019 2:05:16] - Miranda NG MDBX database driver
¤ Dbx_mmap.dll v.0.95.8.1 [18 Feb 2019 2:03:56] - Miranda NG mmap database driver
¤ Dbx_sqlite.dll v.0.95.10.2 [2 Feb 2019 2:04:30] - Miranda NG SQLite database driver
¤ Discord.dll v.0.6.1.1 [8 Feb 2019 2:13:34] - Discord protocol
¤ Dummy.dll v.0.2.0.0 [18 Feb 2019 2:04:54] - Dummy protocol
¤ historypp.dll v.1.5.1.5 [12 Feb 2019 2:05:38] - History++
¤ ICQ.dll v.0.95.11.3 [17 Feb 2019 2:04:38] - ICQ-WIM protocol
¤ Import.dll v.0.95.10.1 [18 Feb 2019 2:04:14] - Import contacts and messages
¤ IRC.dll v.0.95.10.1 [8 Feb 2019 2:11:48] - IRC protocol
¤ Jabber.dll v.0.11.0.5 [15 Feb 2019 13:20:02] - Jabber protocol
¤ MSN.dll v.0.95.11.1 [10 Feb 2019 13:33:04] - MSN protocol
¤ PluginUpdater.dll v.0.2.0.2 [8 Feb 2019 2:12:30] - Plugin updater
¤ SkypeWeb.dll v.0.12.3.2 [15 Feb 2019 13:20:38] - Skype protocol (Web)

Protocols and Accounts:
-------------------------------------------------------------------------------
Discord                  1 - Enabled 0 - Disabled  Loaded
ICQ                      1 - Enabled 0 - Disabled  Loaded
MSN                      1 - Enabled 0 - Disabled  Loaded
SKYPE                    1 - Enabled 0 - Disabled  Loaded

Icon Packs:
-------------------------------------------------------------------------------
 HistoryPP_icons.dll [12 Feb 2019 2:05:28]
 Proto_Discord.dll [8 Feb 2019 2:17:06]
 Proto_Dummy.dll [18 Feb 2019 2:05:30]
 Proto_ICQ.dll [17 Feb 2019 2:05:02]
 Proto_IRC.dll [8 Feb 2019 2:16:56]
 Proto_Jabber.dll [15 Feb 2019 13:21:04]
 Proto_MetaContacts.dll [18 Feb 2019 2:05:30]
 Proto_MRA.dll [17 Feb 2019 2:05:02]
 Proto_MSN.dll [10 Feb 2019 13:34:16]
 Proto_Skype.dll [15 Feb 2019 13:21:06]
 xStatus_Jabber.dll [15 Feb 2019 13:21:04]

edit2: I've been using the latest 64bit development version with auto updates enabled
« Last Edit: 19 02 2019, 19:26:00 by johndoe »
 

Offline dartraiden

  • Beta Tester
  • *****
  • Posts: 1031
  • Country: ru
  • Karma: 35
  • Version Info
Re: Discord Not Connecting
« Reply #1 on: 19 02 2019, 19:41:38 »
Need a netlog
_██_
(°ᴗƪ)
 
The following users thanked this post: johndoe

Offline johndoeTopic starter

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
Re: Discord Not Connecting
« Reply #2 on: 19 02 2019, 20:27:25 »
Spoiler
[23:23:21 11A0] [Discord_1] CDiscordProto::SetStatus iNewStatus = 40072, m_iStatus = 40071, m_iDesiredStatus = 40071 m_hWorkerThread = 0000000000000000
[23:23:21 1158] [Discord_1] CDiscordProto::WorkerThread: entering
[23:23:21 1158] [Discord_1] Executing request #55:
https://discordapp.com/api/v6/users/@me
[23:23:21 1158] [Discord_1] Connection request to discordapp.com:443 (Flags 11)....
[23:23:21 1158] [Discord_1] (0000000009D10800) Connecting to server discordapp.com:443....
[23:23:21 1158] [Discord_1] (0000000009D10800) Connecting to ip 104.16.59.5:443 ....
[23:23:21 1158] [Discord_1] (5772) Connected to discordapp.com:443
[23:23:21 1158] [Discord_1] (5772 discordapp.com) Starting SSL negotiation
[23:23:21 1158] [Discord_1] (5772 discordapp.com) SSL negotiation successful
[23:23:21 1158] [Discord_1] (0000000009D10800:5772) Data sent
GET /api/v6/users/@me HTTP/1.1
Authorization: NTMwNDMwNzQ1MjUzMjQ5MDI1.D03kRw.D4ypn-PztSB91Pj7ygK3jW1O-A0
Content-Type: application/json
Cookie: __cfduid=d2f78f332cd49af54189b059d771ebcc91550602951
User-Agent: Miranda/0.95.11.21416 (x64)
Accept-Encoding: deflate, gzip
Host: discordapp.com
Connection: Keep-Alive
Proxy-Connection: Keep-Alive

[23:23:21 1158] [Discord_1] (0000000009D10800:5772) Data received
HTTP/1.1 200 OK
Date: Tue, 19 Feb 2019 20:23:20 GMT
Content-Type: application/json
Transfer-Encoding: chunked
Connection: keep-alive
Strict-Transport-Security: max-age=31536000; includeSubDomains
Content-Encoding: gzip
Via: 1.1 google
Alt-Svc: clear
Expect-CT: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
Server: cloudflare
CF-RAY: 4abb735e3dd4a7a6-IST

b1
‹
{"username": "xxxxxxx", "verified": true, "locale": "en-US", "mfa_enabled": false, "id": "530430745253249025", "phone": null, "flags": 0, "avatar": null, "discriminator": "6103", "email": "xxxxxxxx"}
[23:23:21 1158] [Discord_1] CDiscordProto::OnLoggedIn
[23:23:21 1158] [Discord_1] Executing request #56:
https://discordapp.com/api/v6/users/@me/settings
[23:23:21 1E14] [Discord_1] Gateway connection failed to connect to gateway.discord.gg:443, exiting
[23:23:21 1E14] [Discord_1] CDiscordProto::ShutdownSession
[23:23:21 1E14] [Discord_1] CDiscordProto::OnLoggedOut
[23:23:21 1158] [Discord_1] (0000000009D10800:5772) Data sent
PATCH /api/v6/users/@me/settings HTTP/1.1
Authorization: NTMwNDMwNzQ1MjUzMjQ5MDI1.D03kRw.D4ypn-PztSB91Pj7ygK3jW1O-A0
Content-Type: application/json
Cookie: __cfduid=d2f78f332cd49af54189b059d771ebcc91550602951
User-Agent: Miranda/0.95.11.21416 (x64)
Accept-Encoding: deflate, gzip
Host: discordapp.com
Connection: Keep-Alive
Proxy-Connection: Keep-Alive
Content-Length: 19

[23:23:21 1158] [Discord_1] (0000000009D10800:5772) Connection closed internal
[23:23:21 1158] [Discord_1] (0000000009D10800:4294967295) Connection closed
[23:23:21 1158] [Discord_1] Request 56 failed
[23:23:21 1158] [Discord_1] CDiscordProto::WorkerThread: leaving

is this good enough ? I removed my username and e-mail well its a throwaway email anyways
« Last Edit: 19 02 2019, 20:28:58 by johndoe »
 

Offline ghazan

  • Miranda NG founder
  • Administrator
  • *****
  • Posts: 746
  • Country: ru
  • Karma: 47
  • Jabber ID
Re: Discord Not Connecting
« Reply #3 on: 19 02 2019, 20:32:22 »
johndoe,
can you run
>telnet gateway.discord.gg 443
and check whether it works or not?
is this dns name resolved ok?
 
The following users thanked this post: johndoe

Offline johndoeTopic starter

  • Newbie
  • *
  • Posts: 13
  • Karma: 0
Re: Discord Not Connecting
« Reply #4 on: 19 02 2019, 20:51:13 »
johndoe,
can you run
>telnet gateway.discord.gg 443
and check whether it works or not?
is this dns name resolved ok?

I couldn't figure out where to write it and instead of asking that, I just reinstalled miranda now it works thx for your time
but still why wasn't it connecting before we'll never know


Also my other problem still stands is that also something only I encountered or do the group msgs behave like that for everyone ?
 

Offline ghazan

  • Miranda NG founder
  • Administrator
  • *****
  • Posts: 746
  • Country: ru
  • Karma: 47
  • Jabber ID
Re: Discord Not Connecting
« Reply #5 on: 20 02 2019, 21:14:34 »
I couldn't figure out where to write it and instead of asking that
in the command line. WinKey+R, type in "cmd" there and press Enter

still why wasn't it connecting before we'll never know
maybe your DNS server finally came in the good mood :)

Also my other problem still stands is that also something only I encountered or do the group msgs behave like that for everyone ?
we already have that ticket in our bug tracker, you can subscribe on it, so you will notified on fix.
https://github.com/miranda-ng/miranda-ng/issues/1843