Author Topic: Hangout - how to configure?  (Read 1212 times)

0 Members and 1 Guest are viewing this topic.

Offline gskoczylasTopic starter

  • Newbie
  • *
  • Posts: 6
  • Country: pl
  • Karma: 0
  • Version Info
Hangout - how to configure?
« on: 05 12 2017, 20:35:45 »
Until now I used the Jabber plug-in to contact Google Talk. Since the latest version of Miranda this way is no longer available.

How should I configure Miranda to use Google Hangout?
--
Kind regards,
Grzegorz Skoczylas
 

Offline ghazan

  • Miranda NG founder
  • Administrator
  • *****
  • Posts: 519
  • Country: ru
  • Karma: 38
  • Jabber ID
Re: Hangout - how to configure?
« Reply #1 on: 07 12 2017, 12:24:50 »
GoogleTalk plugin only catched Google mail notifications.
Since Google stopped sending them through XMPP, this feature became useless, and thus we moved GoogleTalk to deprecated plugins

You can use GmailNotifier plugin to be notified about Google mail, or use simple Jabber plugin to send/receive messages through Google. There is a predefined setting for Google accounts inside Jabber:
 
The following users thanked this post: gskoczylas

Offline gskoczylasTopic starter

  • Newbie
  • *
  • Posts: 6
  • Country: pl
  • Karma: 0
  • Version Info
Odp: Hangout - how to configure?
« Reply #2 on: 12 12 2017, 18:24:39 »
I downloaded the Jabber plug-in (https://wiki.miranda-ng.org/index.php?title=Plugin:Jabber/pl). Now I can see the Jabber protocol in the Accounts window, but there is also information Protocol is not loaded and information in the right panel Account is disabled. Please activate it to access options.

So, what should I do to activate this account (my Google account is active)?  :-[
--
Kind regards,
Grzegorz Skoczylas
 

Offline dartraiden

  • Localization Maintainer
  • *****
  • Posts: 417
  • Country: ru
  • Karma: 15
  • Jabber ID
  • Version Info
Re: Hangout - how to configure?
« Reply #3 on: 12 12 2017, 21:26:55 »
Turn on the checkbox to the left of it
_██_
(°ᴗƪ)
 

Offline gskoczylasTopic starter

  • Newbie
  • *
  • Posts: 6
  • Country: pl
  • Karma: 0
  • Version Info
Re: Hangout - how to configure?
« Reply #4 on: 16 12 2017, 19:58:31 »
Are you joking?

Just in case you have written this seriously: the protocol is checked-on but it does not have any effect.

Of course Google Talk account is configured (login and password configured in plug-in)
--
Kind regards,
Grzegorz Skoczylas
 

Offline dartraiden

  • Localization Maintainer
  • *****
  • Posts: 417
  • Country: ru
  • Karma: 15
  • Jabber ID
  • Version Info
Re: Hangout - how to configure?
« Reply #5 on: 17 12 2017, 00:58:12 »
Disabled protocol is one of the reasons that can cause "Protocol is not loaded".
Another reason may be the following: do you have a libaxolotl.mir in /Libs/ subfolder?
But seems like Jabber is loaded, so "Protocol is not loaded" message is strange...
_██_
(°ᴗƪ)
 

Offline ghazan

  • Miranda NG founder
  • Administrator
  • *****
  • Posts: 519
  • Country: ru
  • Karma: 38
  • Jabber ID
Re: Hangout - how to configure?
« Reply #6 on: 17 12 2017, 10:37:20 »
Options - Contact list - Accounts, check Jabber.
 
The following users thanked this post: gskoczylas

Offline gskoczylasTopic starter

  • Newbie
  • *
  • Posts: 6
  • Country: pl
  • Karma: 0
  • Version Info
Re: Hangout - how to configure?
« Reply #7 on: 20 12 2017, 20:27:16 »
Wow!  :THUMBS UP: Just few minues age I found, that this protocol was disabled there. :-)

Now I can see Jabber icon in the status bar but still can't turn this protocol to the Online state.

I tried to find reason and configured network logging. Now in the netlog.txt file I see the following information (fragments):

[21:19:13 4E30] [JABBER] Connection request to talk.google.com:443 (Flags 0)....
[21:19:13 4E30] [JABBER] (049189D8) Connecting to server talk.google.com:443....
...
[21:19:13 4E30] [JABBER] (049189D8) Connecting to ip 173.194.220.125:443 ....
[21:19:13 4E30] [JABBER] (2020) Connected to talk.google.com:443
[21:19:13 4E30] [JABBER] Thread type=0 server='talk.google.com' port='443'
[21:19:13 4E30] [JABBER] Intializing SSL connection
[21:19:13 4E30] [JABBER] (2020 talk.google.com) Starting SSL negotiation
[21:19:13 4E30] [JABBER] (2020 talk.google.com) SSL negotiation successful
[21:19:13 4E30] [JABBER] Stream is initializing after connect
[21:19:13 4E30] [JABBER] (049189D8:2020) Data sent
<?xml version="1.0" encoding="UTF-8"?><stream:stream xmlns="jabber:client" to="gmail.com" xmlns:stream="http://etherx.jabber.org/streams" xml:lang="pl" version="1.0">
[21:19:13 4E30] [JABBER] Entering main recv loop
[21:19:14 4E30] [JABBER] (049189D8:2020) Data received
<stream:stream from="gmail.com" id="320D550781C35200" version="1.0" xmlns:stream="http://etherx.jabber.org/streams" xmlns="jabber:client">
[21:19:14 4E30] [JABBER] recvResult = 138
[21:19:14 4E30] [JABBER] bytesParsed = 138
[21:19:14 4E30] [JABBER] (049189D8:2020) Data received
...
[21:19:14 4E30] [JABBER] (049189D8:2020) Data sent
<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN"> ... =</auth>
[21:19:14 4E30] [JABBER] (049189D8:2020) Data received
<failure xmlns="urn:ietf:params:xml:ns:xmpp-sasl"><not-authorized/></failure>
[21:19:14 4E30] [JABBER] recvResult = 77
[21:19:14 4E30] [JABBER] bytesParsed = 77
[21:19:14 4E30] [JABBER] (049189D8:2020) Data sent
<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN"> ... ==</auth>
[21:19:14 4E30] [JABBER] (049189D8:2020) Data received
</stream:stream>
[21:19:14 4E30] [JABBER] recvResult = 16
[21:19:14 4E30] [JABBER] bytesParsed = 0
[21:19:14 4E30] [JABBER] Unknown state: bytesParsed=0, datalen=16, jabberNetworkBufferSize=2048
[21:19:14 4E30] SSL connection gracefully closed
[21:19:14 4E30] [JABBER] Connection closed gracefully


I'm pretty sure that password is correct. I try to find the reason why Google rejects my authorisation.
« Last Edit: 21 12 2017, 00:18:15 by gskoczylas »
--
Kind regards,
Grzegorz Skoczylas
 

Offline dartraiden

  • Localization Maintainer
  • *****
  • Posts: 417
  • Country: ru
  • Karma: 15
  • Jabber ID
  • Version Info
Re: Hangout - how to configure?
« Reply #8 on: 20 12 2017, 20:59:25 »
Just note: Miranda doesn't support 2-factor authorization.
_██_
(°ᴗƪ)
 

Offline gskoczylasTopic starter

  • Newbie
  • *
  • Posts: 6
  • Country: pl
  • Karma: 0
  • Version Info
Re: Hangout - how to configure?
« Reply #9 on: 21 12 2017, 00:24:38 »
Hmm... Does this mean that I should turn it off to be able use Google Talk in Miranda?
What about Google account security?
--
Kind regards,
Grzegorz Skoczylas
 

Offline dartraiden

  • Localization Maintainer
  • *****
  • Posts: 417
  • Country: ru
  • Karma: 15
  • Jabber ID
  • Version Info
Re: Hangout - how to configure?
« Reply #10 on: 21 12 2017, 00:29:31 »
You can create application password for using with Miranda.
https://support.google.com/mail/answer/185833

If the application password is compromised, you can easily revoke it and generate a new one without changing the main account password. And this will save 2-factor authorization enabled for other applications.
_██_
(°ᴗƪ)
 
The following users thanked this post: ghazan, gskoczylas

Offline gskoczylasTopic starter

  • Newbie
  • *
  • Posts: 6
  • Country: pl
  • Karma: 0
  • Version Info
Re: Hangout - how to configure?
« Reply #11 on: 23 12 2017, 14:41:41 »
It works. Thanks for your support!  :)
--
Kind regards,
Grzegorz Skoczylas