Author Topic: Miranda on Wine doesn't start  (Read 5314 times)

0 Members and 1 Guest are viewing this topic.

Offline lockheed

  • Newbie
  • *
  • Posts: 1
Miranda on Wine doesn't start
« on: 17 04 2016, 09:47:03 »
I followed the wiki guide, but miranda won't start:
Code: [Select]
$ sh ~/.wines/miranda/drive_c/Miranda_NG/
fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
fixme:msvcrt:__clean_type_info_names_internal (0x13826054) stub
fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32f2b8 1 C) semi-stub
fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32f088 1 C) semi-stub
fixme:dbghelp:elf_search_auxv can't find symbol in module

the wiki guide contains an error here:
Code: [Select]
Copy Miranda NG files to directory $HOME/.wines/miranda/Miranda_NG/should be:
Code: [Select]
Copy Miranda NG files to directory $HOME/.wines/miranda/drive_c/Miranda_NG/

Offline Wishmaster

Re: Miranda on Wine doesn't start
« Reply #1 on: 17 04 2016, 09:57:44 »
Well, first of all please provide a Versionsinformation and the Linux-distribution you are using. Try with a minimal version and try to track the plugin that causes a problem. And did you copy the libraries into  $HOME/.wines/miranda/drive_c/windows/system32/ ?

PS: I fixed the tutorial, thanks :)
« Last Edit: 17 04 2016, 10:40:25 by Wishmaster »

Offline ZAJDAN

  • Newbie
  • *
  • Posts: 1
  • Country: cz
Re: Miranda on Wine doesn't start
« Reply #2 on: 10 04 2018, 12:17:19 »
I am facing the same problem
Debian 8 x64 KDE

step 1)
Code: [Select]
#apt-get install wine
#apt-get install winetricks
#apt-get install winbind

step 2) install MIRANDA
Code: [Select]
$wine32 /home/zajdan/Downloads/Miranda-NG_Watcher_Pack_v5.4.2.exe

step 3) here I added all the required library via wine GUI
Code: [Select]

step 4) start MIRANDA
Code: [Select]
$wine32 /home/zajdan/.wine/drive_c/Program\ Files/Miranda\ NG\ Watcher\ Pack/miranda32.exe
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
wine: Unhandled page fault on write access to 0x00000010 at address 0x458e99 (thread 0009), starting debugger...

Code: [Select]
Unhandled exception: page fault on write access to 0x00000010 in 32-bit code (0x00458e99).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:00458e99 ESP:0032f1cc EBP:0032f3f4 EFLAGS:00210202(  R- --  I   - - - )
 EAX:00000000 EBX:0032f3f3 ECX:0068b101 EDX:00000000
 ESI:00683a50 EDI:00640118
Stack dump:
0x0032f1cc:  1201dcd4 fffffffd 00000000 0032f218
0x0032f1dc:  00110000 00000001 7bc36596 0032f210
0x0032f1ec:  7bc36686 0032f210 7eb09ef0 0032f248
0x0032f1fc:  7eaca3c3 7eb14e20 7bc36596 0032f230
0x0032f20c:  7bc36686 0032f230 7eb09ef0 0032f268
0x0032f21c:  7eaca3c3 7eb14e20 012500e9 7ea687e9
=>0 0x00458e99 in miranda32 (+0x58e99) (0x0032f3f4)
  1 0x1200c9bc in mir_core (+0xc9bb) (0x0032f40c)
  2 0x143e34cd in uinfoex (+0x134cc) (0x0032f480)
  3 0x143e3a0c in uinfoex (+0x13a0b) (0x0032f4b0)
  4 0x143f4e38 in uinfoex (+0x24e37) (0x0032f4d0)
  5 0x0042edbf in miranda32 (+0x2edbe) (0x0032f91c)
  6 0x0042f51b in miranda32 (+0x2f51a) (0x0032fd68)
  7 0x00401a4d in miranda32 (+0x1a4c) (0x0032fd78)
  8 0x0040139b in miranda32 (+0x139a) (0x0032fdbc)
  9 0x0045d3b1 in miranda32 (+0x5d3b0) (0x0032fe50)
  10 0x7b85a9bc in kernel32 (+0x4a9bb) (0x0032fe68)
  11 0x7b85b9ca in kernel32 (+0x4b9c9) (0x0032fe98)
  12 0x7bc72f60 (0x0032feb8)
  13 0x7bc75d7f (0x0032ffa8)
  14 0x7bc72f3e (0x0032ffc8)
  15 0x7bc4acf7 (0x0032ffe8)
0x00458e99: incl 0x10(%eax)
Module Address Debug info Name (82 modules)
PE   400000-  4bb000 Export          miranda32
PE 12000000-12022000 Export          mir_core
PE 120a0000-120c8000 Deferred        pcre3
PE 12100000-12117000 Deferred        zlib
PE 12220000-1222c000 Deferred        stdcrypt
PE 12300000-12307000 Deferred        stdssl
PE 12e50000-12ea6000 Deferred        actman
PE 12f10000-12f9e000 Deferred        advaimg
PE 13070000-13077000 Deferred        authstate
PE 13090000-130a2000 Deferred        avs
PE 130d0000-130d8000 Deferred        bass_interface
PE 130f0000-130fb000 Deferred        bosskey
PE 13110000-1311c000 Deferred        buddyexpectator
PE 13130000-131a8000 Deferred        clist_modern
PE 13230000-13240000 Deferred        crashdumper
PE 13270000-1328b000 Deferred        dbeditorpp
PE 132b0000-132c1000 Deferred        dbx_mmap
PE 132f0000-132f9000 Deferred        db_autobackups
PE 13390000-133a9000 Deferred        fingerprint
PE 133d0000-133e0000 Deferred        gtalkext
PE 133f0000-135df000 Deferred        historypp
PE 137d0000-137d8000 Deferred        historysweeperlight
PE 137f0000-13842000 Deferred        icq
PE 138f0000-138fd000 Deferred        import
PE 13910000-13970000 Deferred        importtxt
PE 139d0000-13a1d000 Deferred        irc
PE 13a70000-13b01000 Deferred        jabber
PE 13bb0000-13bc0000 Deferred        keepstatus
PE 13c10000-13c1e000 Deferred        menuex
PE 13c30000-13cc9000 Deferred        mirotr
PE 13d70000-13d76000 Deferred        mobilestate
PE 13f10000-13f30000 Deferred        newxstatusnotify
PE 13f70000-13f81000 Deferred        packupdater
PE 13fb0000-13fb8000 Deferred        pmanagerex
PE 13fd0000-14003000 Deferred        popup
PE 14050000-14082000 Deferred        quicksearch
PE 140d0000-140ec000 Deferred        smileyadd
PE 141b0000-141c1000 Deferred        startupstatus
PE 141f0000-141fc000 Deferred        stopspam
PE 14210000-1429e000 Deferred        tabsrmm
PE 14330000-14358000 Deferred        tipper
PE 143b0000-143ba000 Deferred        translitswitcher
PE 143d0000-14427000 Export          uinfoex
PE 6de80000-6df06000 Deferred        msftedit
PE 74c40000-74caf000 Deferred        riched20
PE 76f50000-76f63000 Deferred        secur32
PE 78050000-780b9000 Deferred        msvcp100
PE 78aa0000-78b5f000 Deferred        msvcr100
PE 7b810000-7b9ad000 Export          kernel32
PE 7bc10000-7bc14000 Deferred        ntdll
PE 7d810000-7d814000 Deferred        dwmapi
PE 7d820000-7d82a000 Deferred        mpr
PE 7d850000-7d868000 Deferred        wininet
PE 7d8c0000-7d8c3000 Deferred        netapi32
PE 7d8f0000-7d8f4000 Deferred        dnsapi
PE 7da10000-7da13000 Deferred        wtsapi32
PE 7da30000-7da34000 Deferred        gdiplus
PE 7dac0000-7dac4000 Deferred        msvcrt
PE 7db80000-7db83000 Deferred        msimg32
PE 7dba0000-7dba4000 Deferred        iphlpapi
PE 7dbc0000-7dbc4000 Deferred        wsock32
PE 7dbe0000-7dc20000 Deferred        crypt32
PE 7dca0000-7dca4000 Deferred        psapi
PE 7dd20000-7dd24000 Deferred        dbghelp
PE 7dd80000-7dd84000 Deferred        imm32
PE 7dfd0000-7dfd4000 Deferred        winex11
PE 7e250000-7e258000 Deferred        oleaut32
PE 7e360000-7e369000 Deferred        winspool
PE 7e3b0000-7e50d000 Deferred        shell32
PE 7e5d0000-7e668000 Deferred        comdlg32
PE 7e6b0000-7e6b8000 Deferred        shlwapi
PE 7e720000-7e724000 Deferred        uxtheme
PE 7e760000-7e769000 Deferred        msacm32
PE 7e790000-7e794000 Deferred        rpcrt4
PE 7e810000-7e818000 Deferred        ole32
PE 7e930000-7e9a7000 Deferred        winmm
PE 7e9f0000-7e9f4000 Deferred        advapi32
PE 7ea60000-7ea67000 Deferred        gdi32
PE 7eb80000-7ebbb000 Deferred        user32
PE 7ecc0000-7ecef000 Deferred        comctl32
PE 7edc0000-7edc4000 Deferred        ws2_32
PE 7eff0000-7eff4000 Deferred        version
process  tid      prio (all id:s are in hex)
00000008 (D) C:\Program Files\Miranda NG Watcher Pack\miranda32.exe
00000029    0
00000028    0
00000027    0
00000026    0
00000025    0
00000024    0
00000009    0 <==
0000000e services.exe
0000001e    0
0000001d    0
00000014    0
00000010    0
0000000f    0
00000012 winedevice.exe
0000001c    0
00000019    0
00000017    0
00000013    0
0000001a plugplay.exe
00000020    0
0000001f    0
0000001b    0
00000021 explorer.exe
00000023    0
00000022    0
System information:
    Wine build: wine-1.6.2
    Platform: i386
    Host system: Linux
    Host version: 3.16.0-5-amd64
« Last Edit: 10 04 2018, 12:28:13 by ZAJDAN »

Offline yvesson

Re: Miranda on Wine doesn't start
« Reply #3 on: 02 05 2018, 19:42:45 »
I feel very stupid...
I tryed and followed the tutorial, finally got to run miranda with the old database plugin, it started, but then it updated and it no longet starts after that, says "the error was 1", and the "myprofile.dat is in an unknown format. :/

I'm on Lubuntu btw.

Offline Goraf

Re: Miranda on Wine doesn't start
« Reply #4 on: 02 05 2018, 21:10:53 »
yvesson, do you also have a new database plugin in your Miranda? If not then try to add it and see what will happen. Or create now an additional test profile and see if it will run.

Offline yvesson

Re: Miranda on Wine doesn't start
« Reply #5 on: 03 05 2018, 10:24:28 »
It's a fresh profile, it creates okej with the old database plugin, but when miranda updates with the new one, then I get the error.
Same error when I create a fresh profile with the new database plugin directly.
« Last Edit: 03 05 2018, 10:26:02 by yvesson »

Offline J.L.

Re: Miranda on Wine doesn't start
« Reply #6 on: 08 05 2018, 22:30:39 »
please, update

for 0.95.7 in ubuntu 17.10+wine-3.7 (Staging?) need only:
0) StdMsg.dll work fine
1) historypp.dll need winetricks riched30  (and break StdMsg.dll)
2) now StdMsg.dll need winetricks msftedit
not see what not worked, use wine+miranda ~10 yo, and not see it on win
i not use/test tabsrmm or cls_modern (but see yesterday that cls_modern can start)
The following users thanked this post: dartraiden

Offline dartraiden

Re: Miranda on Wine doesn't start
« Reply #7 on: 08 05 2018, 22:40:58 »
Please note that new database driver may crash under Wine.

Offline dartraiden

Re: Miranda on Wine doesn't start
« Reply #8 on: 09 02 2021, 17:49:22 »
Just tested on Ubuntu 20.10 + wine-staging + Miranda x64. All OK.
It does not work on wine-stable or wine-devel. Also Miranda x32 does not work too.

It's recommended to use dbx_sqlite database driver, not dbx_mdbx.