Author Topic: Miranda HotCoffee  (Read 278027 times)

0 Members and 1 Guest are viewing this topic.

Offline Dracosha

Re: Miranda HotCoffee
« Reply #675 on: 11 04 2022, 18:21:34 »
AngelNet,
Я же уже освещал свою позицию немного ранее по этому поводу.
Для таких случаев в сборке предусмотрен плагин PluginUpdater, который позволяет установить любой недостающий в сборке плагин следующим образом:
1. Для начала в обязательном порядке требуется обновить всю миранду.
Главное меню > Обновить > Проверить обновления > обновляем всё что предлагается.
[close]
2. После обновления можно отказаться от перезагрузки и сразу приступить к установке недостающих компонентов.
Главное меню > Обновить > Установка компонентов... > выбираем недостающий нам плагин например MirOTR и устанавливаем его.
[close]
3. После установки компонента можно отказаться от перезагрузки и приступить сразу к патчу любимого пака иконок.
Главное меню > Вид > Значки... > выбираем любимый пак иконок и устанавливаем его.
[close]
 

Offline AngelNet

  • Newbie
  • *
  • Posts: 27
  • Country: ru
Re: Miranda HotCoffee
« Reply #676 on: 11 04 2022, 18:53:31 »
Dracosha, простите, я не понял из вашего ответа: выпиливание из сборки плагина это ваш личный каприз или отказ автора миранды его поддерживать?
если первое, то я отключил обновление сборки буду сидеть на ней пока не "протухнет насмерть", если второе - то мне стоит начинать искать альтернативный клиент.

есть такая пословица: "мы в ответе за тех кого мы приручили".
также и с пользователями. несколько лет назад мне посоветовали вашу сборку именно по одной простой причине: наличие в ней поддержки ОТР в jabber.

особенно это стало актуально сейчас, когда отвалился корпоративный месенджер Slack
« Last Edit: 11 04 2022, 18:55:20 by AngelNet »
 

Offline Dracosha

Re: Miranda HotCoffee
« Reply #677 on: 11 04 2022, 19:15:03 »
AngelNet, ну если мои аргументы считаете невесомыми, тогда пусть будет "мой личный каприз" :)
 

Offline dartraiden

Re: Miranda HotCoffee
« Reply #678 on: 12 04 2022, 11:48:33 »
Я что-то не въезжаю в проблему. В чём проблема самостоятельно установить любой нужный плагин?

Вообще, мне кажется, лучше потратить N-ное время и настроить Миранду самостоятельно, взяв "ванильный" дистрибутив и добавив туда желаемые плагины, скины, настройки и прочее. Не используя никакие сборки, и не завися от их авторов.
« Last Edit: 12 04 2022, 11:52:37 by dartraiden »
 
The following users thanked this post: AngelNet

Offline AngelNet

  • Newbie
  • *
  • Posts: 27
  • Country: ru
Re: Miranda HotCoffee
« Reply #679 on: 12 04 2022, 16:18:21 »
dartraiden,
александр, для меня миранда это ужасный монстр (уж простите за эпитеты) в котором нет никакой обратной совместимости компонентов и все настолько запутано и запущено, что лучше не связываться с его потрошением и вниканием в суть дела.
мне дорого свое время, проще взять сборку где будет все "искаропки",  вбить логин пасс и пользоваться не зная боли горя.
однажды я пытался обновить компоненты дискорда и вк простым подкидыванием свежих длл и ресурсных файлов, но быстро обломался, т.к. миранда не хотела кушать новые компонеты(
наступив на эти грабли, настроил сборку как мог и забыл на несколько лет о ее обновлении.
за эти несколько лет отпала надобность в иных протоколах (аська, вк, дискорд итп.) остался лишь жаббер с отр.
в этом случае мне видится весьма разумным ВАШ совет по настройке ванильного дистрибутива, раз автор его не дропал из поддержки миранды.
остается только вопрос насколько будет портабельным ванильный дистрибутив по сравнению с HotCoffee ?
в последнем, меня как раз подкупала портативность и то что сборка не гадит ни в реестр ни в файловую систему ОС, а для меня это крайне критично.
(почти весь мой софт на флешке и завернут в виртуальные машины/портабелизацией).
« Last Edit: 12 04 2022, 16:22:56 by AngelNet »
 

Offline dartraiden

Re: Miranda HotCoffee
« Reply #680 on: 12 04 2022, 19:58:39 »
Есть правила успешного обновления:
- обновлять нужно только PluginUpdater-ом, никакого подкидывания файлов вручную, тогда и проблем не будет. Все проблемы идут от того, что пользователь берёт плагин от одной версии и кидает его к Миранде другой версии, ну а Миранда, конечно, не примет такой винегрет
- обновлять нужно всё, что нашёл PluginUpdater. Чтобы все компоненты и плагины были от одного и того же билда, опять же, чтобы не получался винегрет из версий
- перед установкой плагина стоит убедиться, что Миранда обновлена до упора, и опять же, чтобы не получался винегрет из какой-то более старой Миранды и нового плагина (например, стоит старая стабильная версия 0.95.12, а пользователь пытается поставить плагин от текущей стабильной 0.95.13, думая "ну там стабильная, и тут стабильная" - ан нет, версия-то разная)

По сути, всё сводится к тому, что красным написано на первой же странице в вики - обратной совместимости никто не обещает.

А портативна Миранда "из коробки", если, конечно, не использовать плагины типа AssocMgr или AutoRun, которые и предназначены для интеграции Миранды в систему.
« Last Edit: 12 04 2022, 20:13:42 by dartraiden »
 
The following users thanked this post: Dracosha, AngelNet