Author Topic: Facebook unable to connect  (Read 44703 times)

0 Members and 1 Guest are viewing this topic.

Offline sloppdawop

  • Newbie
  • *
  • Posts: 18
  • Country: de
Re: Facebook unable to connect
« Reply #15 on: 03 10 2015, 18:26:30 »
plugin is using classic webpage (and pretending to be webbrowser). And I'm periodically adapting it to any new website changes :-)
Would this be possible for Google aswell? I'm asking because Google lately abandonded XAMPP support as it seems. Can't use Miranda for Google anymore now
 

Offline Robyer

Re: Facebook unable to connect
« Reply #16 on: 03 10 2015, 19:25:59 »
sloppdawop, theoretically it's possible, but it needs dedicated developer as it might be very time consuming. I don't think there is anyone interested right now from actual devs...
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline HeBu

  • Newbie
  • *
  • Posts: 1
Re: Facebook unable to connect
« Reply #17 on: 12 10 2015, 19:17:23 »
I also have trouble connecting to Facebook (using latest Miranda NG stable and Facebook RM stable).
Also, I already used the Database Editor to delete the DeviceId.

Connecting to Facebook seems to work, but then the plugin gets a 500 response when calling home() and cancels the sign on process.

This is what my logfile says:

Code: [Select]
[21:02:31 1320] [Facebook_1] === Beginning SetStatus process
[21:02:31 1610] [Facebook_1] [12.10.2015] Using Facebook Protocol RM 0.2.10.8
[21:02:31 1610] [Facebook_1] *** Beginning SignOn process
[21:02:31 1610] [Facebook_1] *** Negotiating connection with Facebook
[21:02:31 1610] [Facebook_1]  >> Entering login()
[21:02:31 1610] [Facebook_1] @@@ Sending request to 'https://mbasic.facebook.com/profile.php?v=info'
[21:02:31 1610] [Facebook_1] Connection request to mbasic.facebook.com:443 (Flags 11)....
[21:02:31 1610] [Facebook_1] (0000000006414ED8) Connecting to server mbasic.facebook.com:443....
[21:02:31 1610] [Facebook_1] (0000000006414ED8) Connecting to ip 31.13.92.10:443 ....
[21:02:31 1610] [Facebook_1] (1448) Connected to mbasic.facebook.com:443
[21:02:31 1610] [Facebook_1] (1448 mbasic.facebook.com) Starting SSL negotiation
[21:02:31 1610] [Facebook_1] (1448 mbasic.facebook.com) SSL negotiation successful
[21:02:31 1610] [Facebook_1] @@@ Got response with code 302
[21:02:31 1610] [Facebook_1] @@@ Sending request to 'https://login.facebook.com/login.php?login_attempt=1'
[21:02:31 1610] [Facebook_1] Connection request to login.facebook.com:443 (Flags 11)....
[21:02:31 1610] [Facebook_1] (0000000006415008) Connecting to server login.facebook.com:443....
[21:02:31 1610] [Facebook_1] (0000000006415008) Connecting to ip 31.13.92.10:443 ....
[21:02:31 1610] [Facebook_1] (1464) Connected to login.facebook.com:443
[21:02:31 1610] [Facebook_1] (1464 login.facebook.com) Starting SSL negotiation
[21:02:32 1610] [Facebook_1] (0000000006415008:1464) Connection closed internal
[21:02:32 1610] [Facebook_1] (0000000006415008:4294967295) Connection closed
[21:02:32 1610] [Facebook_1] @@@ Got response with code 302
[21:02:32 1610] [Facebook_1]     Got self user id: 10000**********
[21:02:32 1610] [Facebook_1]  << Quitting login()
[21:02:32 1610] [Facebook_1]  >> Entering home()
[21:02:32 1610] [Facebook_1] @@@ Sending request to 'https://mbasic.facebook.com/editprofile.php?edit=current_city&type=basic'
[21:02:33 1610] [Facebook_1] @@@ Got response with code 200
[21:02:33 1610] [Facebook_1]     Got self dtsg
[21:02:33 1610] [Facebook_1] @@@ Sending request to 'https://mbasic.facebook.com/profile.php?v=info'
[21:02:33 1610] [Facebook_1] @@@ Got response with code 500
[21:02:33 1610] [Facebook_1] !!! home(): Something with Facebook went wrong
[21:02:33 1610] [Facebook_1] (0000000006414ED8:1448) Connection closed internal
[21:02:33 1610] [Facebook_1] (0000000006414ED8:4294967295) Connection closed
[21:02:33 1610] [Facebook_1] *** SignOn failed

Is this known behaviour? Is there a solution to this?
 

Offline Robyer

Re: Facebook unable to connect
« Reply #18 on: 13 10 2015, 07:44:43 »
HeBu, try switching your Miranda to development version. It should work there.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline sloppdawop

  • Newbie
  • *
  • Posts: 18
  • Country: de
Re: Facebook unable to connect
« Reply #19 on: 18 12 2015, 09:32:58 »
Hey Robyer, I have another one. Can't connect since a couple of weeks.

Quote
[10:18:57 0894] [facebook(jabber)] SetAwayMsg called, wParam=40072 lParam=Yep, I'm here.
[10:18:57 0894] [facebook(jabber)] PS_SETSTATUS(40072)
[10:18:57 0EDC] [facebook(jabber)] Thread started: type=0
[10:18:57 0894] KeepStatus: assigning status 40072 to facebook(jabber)
[10:18:57 0894] [facebook(jabber)] SetAwayMsg called, wParam=40072 lParam=Yep, I'm here.
[10:18:57 0EDC] [facebook(jabber)] _xmpp-client._tcp.chat.facebook.com resolved to chat.facebook.com:5222
[10:18:57 0EDC] [facebook(jabber)] Connection request to chat.facebook.com:5222 (Flags 0)....
[10:18:57 0EDC] [facebook(jabber)] (0000000003B32278) Connecting to server chat.facebook.com:5222....
[10:18:57 0EDC] [facebook(jabber)] (0000000003B32278) Connecting to ip 173.252.121.3:5222 ....
[10:18:57 0EDC] [facebook(jabber)] (688) Connected to chat.facebook.com:5222
[10:18:57 0EDC] [facebook(jabber)] Thread type=0 server='chat.facebook.com' port='5222'
[10:18:57 0EDC] [facebook(jabber)] Stream is initializing after connect
[10:18:57 0EDC] [facebook(jabber)] (0000000003B32278:688) Data sent
<?xml version="1.0" encoding="UTF-8"?><stream:stream xmlns="jabber:client" to="chat.facebook.com" xmlns:stream="http://etherx.jabber.org/streams" xml:lang="en" version="1.0">
[10:18:57 0EDC] [facebook(jabber)] Entering main recv loop
[10:18:58 0EDC] [facebook(jabber)] (0000000003B32278:688) Data received
<?xml version='1.0' ?><stream:stream from='chat.facebook.com' id='1' version='1.0' xmlns:stream='http://etherx.jabber.org/streams' xmlns='jabber:client' xml:lang='en'><stream:features><starttls xmlns='urn:ietf:params:xml:ns:xmpp-tls'/><mechanisms xmlns='urn:ietf:params:xml:ns:xmpp-sasl'><mechanism>X-FACEBOOK-PLATFORM</mechanism><mechanism>PLAIN</mechanism></mechanisms></stream:features>
[10:18:58 0EDC] [facebook(jabber)] recvResult = 389
[10:18:58 0EDC] [facebook(jabber)] bytesParsed = 167
[10:18:58 0EDC] [facebook(jabber)] bytesParsed = 222
[10:18:58 0EDC] [facebook(jabber)] Requesting TLS
[10:18:58 0EDC] [facebook(jabber)] (0000000003B32278:688) Data sent
<starttls xmlns="urn:ietf:params:xml:ns:xmpp-tls"/>
[10:18:58 0EDC] [facebook(jabber)] (0000000003B32278:688) Data received
<proceed xmlns='urn:ietf:params:xml:ns:xmpp-tls'/>
[10:18:58 0EDC] [facebook(jabber)] recvResult = 50
[10:18:58 0EDC] [facebook(jabber)] bytesParsed = 50
[10:18:58 0EDC] [facebook(jabber)] Starting TLS...
[10:18:58 0EDC] [facebook(jabber)] (688 chat.facebook.com) Starting SSL negotiation
[10:18:58 0EDC] [facebook(jabber)] (688 chat.facebook.com) SSL negotiation successful
[10:18:58 0EDC] [facebook(jabber)] Stream will be initialized after successful StartTLS
[10:18:58 0EDC] [facebook(jabber)] Stream is initializing after successful StartTLS
[10:18:58 0EDC] [facebook(jabber)] (0000000003B32278:688) Data sent
<?xml version="1.0" encoding="UTF-8"?><stream:stream xmlns="jabber:client" to="chat.facebook.com" xmlns:stream="http://etherx.jabber.org/streams" xml:lang="en" version="1.0">
[10:18:58 0EDC] [facebook(jabber)] (0000000003B32278:688) Data received
<?xml version='1.0' ?><stream:stream from='chat.facebook.com' id='1' version='1.0' xmlns:stream='http://etherx.jabber.org/streams' xmlns='jabber:client' xml:lang='en'><stream:features><mechanisms xmlns='urn:ietf:params:xml:ns:xmpp-sasl'><mechanism>X-FACEBOOK-PLATFORM</mechanism><mechanism>PLAIN</mechanism></mechanisms></stream:features>
[10:18:58 0EDC] [facebook(jabber)] recvResult = 338
[10:18:58 0EDC] [facebook(jabber)] bytesParsed = 167
[10:18:58 0EDC] [facebook(jabber)] bytesParsed = 171
[10:18:58 0EDC] [facebook(jabber)] (0000000003B32278:688) Data sent
<auth xmlns="urn:ietf:params:xml:ns:xmpp-sasl" mechanism="PLAIN">AG5pbHMucG9sdG9yYWN6eWsAdmVyZ2Vzc2VuMTA=</auth>
[10:18:59 0EDC] [facebook(jabber)] (0000000003B32278:688) Data received
<
[10:18:59 0EDC] [facebook(jabber)] recvResult = 1
[10:18:59 0EDC] [facebook(jabber)] bytesParsed = 0
[10:18:59 0EDC] [facebook(jabber)] Unknown state: bytesParsed=0, datalen=1, jabberNetworkBufferSize=2048
[10:18:59 0EDC] [facebook(jabber)] (0000000003B32278:688) Data received
failure xmlns='urn:ietf:params:xml:ns:xmpp-sasl'><not-authorized/><text>plain login failed</text></failure></stream:stream>
[10:18:59 0EDC] [facebook(jabber)] recvResult = 123
[10:18:59 0EDC] [facebook(jabber)] bytesParsed = 0
[10:18:59 0EDC] [facebook(jabber)] Unknown state: bytesParsed=0, datalen=124, jabberNetworkBufferSize=2048
[10:19:04 0EDC] SSL Server signaled SSL Shutdown
[10:19:04 0EDC] [facebook(jabber)] Connection closed gracefully
[10:19:04 0EDC] [facebook(jabber)] recvResult = 0
[10:19:04 0EDC] [facebook(jabber)] Thread ended: type=0 server='chat.facebook.com'
[10:19:04 0EDC] [facebook(jabber)] (0000000003B32278:688) Connection closed internal
[10:19:04 0EDC] [facebook(jabber)] (0000000003B32278:4294967295) Connection closed
[10:19:04 0EDC] [facebook(jabber)] Exiting ServerThread
with SSL instead of TLS it ends here:
Quote
[10:28:12 0B84] [JABBER_1] recvResult = 1
[10:28:12 0B84] [JABBER_1] bytesParsed = 0
[10:28:12 0B84] [JABBER_1] Unknown state: bytesParsed=0, datalen=3, jabberNetworkBufferSize=2048
[10:28:25 11C8] [facebook(jabber)] modules\netlib\netlibopenconn.cpp 720: connect() failed (10060)
[10:28:25 11C8] [facebook(jabber)] Thread type=0 server='chat.facebook.com' port='5223'
[10:28:25 11C8] [facebook(jabber)] Connection failed (10060)
[10:28:25 0894] KeepStatus: cancel on login error (facebook(jabber))
[10:28:25 0894] KeepStatus: assigning status 40071 to facebook(jabber)
[10:28:25 0894] KeepStatus: facebook.j login error, cancel reconnecting
[10:28:25 0894] KeepStatus: Giving up
[10:28:25 0894] KeepStatus: stop checking (failure)
[10:28:25 11C8] [facebook(jabber)] Thread ended, connection failed
[10:28:28 0B84] [JABBER_1] (0000000003B32148:1052) Data sent

Any clue?
 

Offline Robyer

Re: Facebook unable to connect
« Reply #20 on: 18 12 2015, 10:11:45 »
sloppdawop, because connecting to Facebook was announced to be dead since april 2015. Probably they just have a slight delay before they turned it all off.

Just use classic Facebook protocol.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 
The following users thanked this post: sloppdawop

Offline sloppdawop

  • Newbie
  • *
  • Posts: 18
  • Country: de
Re: Facebook unable to connect
« Reply #21 on: 18 12 2015, 22:35:57 »
Oh i didn't know this existed. Works for me! Thanks!

N.
 

Offline pdecrocq

  • Newbie
  • *
  • Posts: 22
Re: Facebook unable to connect
« Reply #22 on: 21 12 2015, 08:24:14 »
Sorry for asking this but where is the "classic Facebook protocol" and how to install it ?
Thanks
 

Offline Robyer

Re: Facebook unable to connect
« Reply #23 on: 21 12 2015, 10:46:39 »
pdecrocq, it's included in core distribution (Miranda's archive and installer).

Also you can download it manually: http://wiki.miranda-ng.org/index.php?title=Plugin:Facebook (or via Plugin Updater's main menu item "Available Components list").

And I highly recommend switching to development version of Miranda NG because in stable version there are many problems. So, use development version of both core and facebook plugin.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline pdecrocq

  • Newbie
  • *
  • Posts: 22
Re: Facebook unable to connect
« Reply #24 on: 21 12 2015, 13:28:24 »
Thanks ! Actually that's the one I'm using. So I just need to switch to the development version and test.
kind regards,
 

Offline pdecrocq

  • Newbie
  • *
  • Posts: 22
Re: Facebook unable to connect
« Reply #25 on: 21 12 2015, 13:36:39 »
So I just did it (update to dev version) : on 1st relaunch I go a missing mir_core.dll error. Re updated and restarted.
Currently : Skype interface no longer working (seems normal since protocol is stated as deprecated).
Facebook still not connecting. Advice on correct parameters welcome.
 

Offline Robyer

Re:Facebook unable to connect
« Reply #26 on: 21 12 2015, 13:53:23 »
pdecrocq, there is new SkypeWeb protocol (which is much better than the old one).

To understand why is your Facebook not connecting, I need some precise info. Netlog would be good.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline pdecrocq

  • Newbie
  • *
  • Posts: 22
Re: Facebook unable to connect
« Reply #27 on: 21 12 2015, 14:08:29 »
Thanks. Here' the log.
(attachment removed to avoid information leakage)
« Last Edit: 21 12 2015, 14:21:50 by pdecrocq »
 

Offline pdecrocq

  • Newbie
  • *
  • Posts: 22
Re: Facebook unable to connect
« Reply #28 on: 21 12 2015, 14:16:57 »
Switched to SkypeWeb OK. Thanks !
 

Offline Robyer

Re: Facebook unable to connect
« Reply #29 on: 21 12 2015, 14:18:56 »
Thanks. Here' the log.

You are NOT using my plugin. You are still connecting via Jabber. Make sure to add Facebook account via Main menu / Accounts / + button ... as usually.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.