Author Topic: XMPP не работает, если включить TLS/SSL  (Read 3633 times)

0 Members and 1 Guest are viewing this topic.

Offline alsTopic starter

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Такая ситуация:

Собственный сервер prosody-0.9.6 с самодельным сертификатом (на CentOS 6.5).
Miranda NG версии 0.95.2 build #9966 на Windows 7 Service Pack 1.
jabber.dll версии 0.11.0.4.

Галочка "Validate SSL certificates" в настройках отключена.

Подключиться к серверу удается, только если в настройках акаунта выбрать "Public XMPP Network".  Если переключить на "Secure XMPP Network" или "Secure XMPP Network (old style)", подключение не проходит.

В логе сервера сказано:

Oct 31 19:49:45 c2s10a45d0      info    Client connected
Oct 31 19:49:45 c2s10a45d0      info    Authenticated as user@example.com
Oct 31 19:49:45 c2s10a45d0      info    Authenticated as user@example.com
Oct 31 19:49:45 c2s10a45d0      info    c2s stream for user@example.com/resource closed: invalid-namespace
Oct 31 19:49:45 c2s10a45d0      info    Client disconnected: connection closed
Oct 31 19:49:45 stanzarouter    warn    Unhandled c2s_destroyed stream element or stanza: query; xmlns=jabber:iq:private: <query xmlns='jabber:iq:private'><roster xmlns='roster:delimiter'/></query>

Картина одинаковая для "Secure XMPP Network" и "Secure XMPP Network (old style)".

Другие клиенты (например, Thunderbird Chat) с этой же клиентской машины работают.

Скажите, пожалуйста, в чем может быть дело?
 

Offline ghazan

нетворк лог бы
 

Offline watcher

als, нетлог миранды, пожалуйста.
Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline alsTopic starter

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Вот network log.
« Last Edit: 31 10 2014, 18:42:51 by als »
 

Offline ghazan

так не бывает. проверь, что у тебя не включена опция совместимости со старыми серверами
миранда после получения ответа stream и разрешенном TLS сразу запускает starttls
а у тебя получается, что оно начинает авторизацию зачем-то
 

Offline alsTopic starter

  • Newbie
  • *
  • Posts: 6
  • Karma: 0
Да!

Опция называется "Disable SASL authentication".  Отключил - заработало.

Спасибо!
 

Offline ghazan

you're welcome