Author Topic: Facebook protocol  (Read 184320 times)

0 Members and 4 Guests are viewing this topic.

Offline šegi

Re: Facebook protocol
« Reply #825 on: 20 03 2020, 07:08:31 »
Contain it two factor authentication?
 

Offline ghazan

Re: Facebook protocol
« Reply #826 on: 20 03 2020, 13:44:53 »
šegi,
You need to enter the app password into Miranda settings in this case.
You can set up an app password at www.facebook.com in Settings - Security & Login - App passwords
 

Offline šegi

Re: Facebook protocol
« Reply #827 on: 20 03 2020, 20:10:25 »
Thanks. I didn't know this features :)
But plugins won't load unread message :/
 
šegi,
You need to enter the app password into Miranda settings in this case.
You can set up an app password at www.facebook.com in Settings - Security & Login - App passwords
 

Offline dartraiden

Re: Facebook protocol
« Reply #828 on: 21 03 2020, 14:44:04 »
_██_
(°ᴗƪ)
 

Offline riki

Re: Facebook protocol
« Reply #829 on: 26 04 2020, 19:01:49 »
Another case of messages not received. I have a network log prepared. I'll send it via PM as it might contain sensitive data.

This netlog was captured while exchanging messages via the browser. Normally all messages would show up in Miranda too (expected and desired behavior). This time, Miranda only showed the messages I sent through Miranda itself.

 
The following users thanked this post: ghazan

Offline ghazan

Re: Facebook protocol
« Reply #830 on: 28 04 2020, 18:20:47 »
riki,
this log is not from very beginning, the question is - do you have ERROR_QUEUE_* in your log?
if yes, attach this fragment please, from the very beginning to this error + 10 lines
 
The following users thanked this post: riki

Offline riki

Re: Facebook protocol
« Reply #831 on: 28 04 2020, 22:02:19 »
 I've sent you a new log. This time, I started logging before going online with FB plugin. The string ERROR_QUEUE is not found anywhere.

Observed behavior: my outgoing messages do show on the website, but do not pass in the upper half of the message window and leave no trace in history++. Ingoing messages are nowhere to be found in Miranda, even if they do arrive on the website.

Thank you  :)
« Last Edit: 28 04 2020, 22:31:32 by riki »
 

Offline ghazan

Re: Facebook protocol
« Reply #832 on: 29 04 2020, 06:35:28 »
riki,
there're some errors from database driver, it might cause problems with storing incoming messages.
I'd recommend to compact your profiles, perhaps it will cure this issue
 

Offline riki

Re: Facebook protocol
« Reply #833 on: 29 04 2020, 11:04:40 »
database compaction failed  :(
 

Offline ghazan

Re: Facebook protocol
« Reply #834 on: 29 04 2020, 12:04:25 »
riki,
so that's really the reason of your problems. there're two evident solutions:
  • you can try to find latest autobackup that could be compacted
  • if not, you can try to create a new fresh profile and import into it from the existing one in the service mode
 

Offline zany

  • Newbie
  • *
  • Posts: 7
  • Country: cz
  • Karma: 0
Re: Facebook protocol
« Reply #835 on: 30 04 2020, 19:48:36 »
I have also this problem, there is this line in netlog:
[21:48:42 3AD0] [Facebook_1] MS: <{"queueEntityId":1000001495*****,"errorCode":"ERROR_QUEUE_OVERFLOW"}>
« Last Edit: 30 04 2020, 19:52:02 by zany »
 

Offline ghazan

Re: Facebook protocol
« Reply #836 on: 01 05 2020, 11:08:51 »
zany,
just fixed it in the dev build, you can try to update
if this fix worked for you, I'd update the stable version
 
The following users thanked this post: zany

Offline zany

  • Newbie
  • *
  • Posts: 7
  • Country: cz
  • Karma: 0
Re: Facebook protocol
« Reply #837 on: 01 05 2020, 16:39:02 »
seems good, messages are correctly received in Miranda. Thanks a lot.
 

Offline riki

Re: Facebook protocol
« Reply #838 on: 27 05 2020, 13:02:14 »
I lost a lot of messages.  :(
Do you think it will be possible one day to get the messages from the FB server?
 

Offline Dorian Gray

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Facebook protocol
« Reply #839 on: 30 05 2020, 07:39:33 »
Hi,
I still have the problem that no history from Facebook is loaded in the conversation-windows. I have tried both stable-version and dev-version, uninstalling the program in between. I have tried clearing the ClientID, DeviceID, token and SID in both versions, and restarting the app.

This is the end of my log:
[09:35:28 148C] [Facebook_1] Received message of type=3, flags=2, body length=87
[09:35:28 148C] [Facebook_1] (0000000007E01400:1340) Data received
00000000: 00 05 2F 74-5F 6D 73 05-D9 78 DA 62-A8 56 2A 2C  ../t_ms.ÙxÚb¨V*,
00000010: 4D 2D 4D 75-CD 2B C9 2C-A9 F4 4C 51-B2 32 35 32  M-MuÍ+É,©ôLQ²252
00000020: 37 36 32 B7-B0 34 D2 51-4A 2D 2A CA-2F 72 CE 4F  762·°4ÒQJ-*Ê/rÎO
00000030: 49 55 B2 52-72 0D 0A F2-0F 8A 0F 0C-75 0D 75 8D  IU²Rr..ò.Š..u.u
00000040: F7 F3 0F 89-77 F3 0F F5-73 51 AA 05-00 00 00 FF  ÷ó.‰wó.õsQª....ÿ
00000050: FF 03 00 8A-4E 13 CF                             ÿ..ŠN.Ï
[09:35:28 148C] [Facebook_1] (0000000007E01400:1340) Data sent
00000000: 40 02 05 D9-                                     @..Ù
[09:35:28 148C] [Facebook_1] UNZIP: <>
[09:35:28 148C] [Facebook_1] MS: <{"queueEntityId":527327892,"errorCode":"ERROR_QUEUE_NOT_FOUND"}>
[09:35:30 1874] UPnP Gateway detected 0, Control URL:
[09:36:27 0D04] [Facebook_1] (0000000007E01400:1340) Data sent
00000000: C2 00                                            Â.
[09:36:27 148C] [Facebook_1] Received message of type=13, flags=0, body length=0

This is the log right after I go online for the Facebook-protocol in MirandaNG.

The messages I write in Miranda, shows up in both Miranda and web-based Facebook.
The messages I receive shows up only in web-based Facebook.
The messages I write in web-based Facebook shows up only in web-based Facebook.
Pretty expected though.

I can see the indication "xxx is typing a message." in Miranda, but no message arrives once it is sent.
« Last Edit: 30 05 2020, 07:57:37 by Dorian Gray »