Author Topic: Steam protocol  (Read 118631 times)

0 Members and 1 Guest are viewing this topic.

Offline Robyer

Re: Steam protocol
« Reply #150 on: 09 12 2014, 15:48:59 »
I believe I first had it happen after you fixed the loop, i.e. commit 11267.
Is it possible for int count = requestsQueue.getCount();  to be null or something like that?
Aha. No, but I guess (and hope) it is just because some race condition of more threads. I'll try to fix it.

When they're away, online, offline - it works just fine with the overlay, see pic below. Those two were set as NA.
Oh you mean contact status icon. Yes, NA and other status icons are missing in proto_steam.dll. I have to create them :-)
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline Robyer

Re: Steam protocol
« Reply #151 on: 09 12 2014, 20:27:32 »
Allright, I commited various changes so tomorrow you'll have some new holy version :D
Main news is support for showing xstatus for playing contacts (and yourself).

There is still many small things that could be done, but I'm pretty satisfied with it's current state and my work last days. I need to work on other projects now (no, not Tox :-D ) so I won't be so active here anymore.  :)
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Online Vulpix

Re: Steam protocol
« Reply #152 on: 10 12 2014, 06:21:05 »
(no, not Tox :-D )

Darn!

But seriously, thank you for all the effort!


Post Merge: 10 12 2014, 17:47:19
NA icons are now shown! Great job~

I also noticed that the people who are playing have a "gamepad" icon of sorts, but I can no longer see which game they are playing (it was showing me that as xstatus before). I have xstatus set as my 3rd row item in clist_modern. Should I change anything according to what you rewrote in the protocol?
« Last Edit: 10 12 2014, 17:47:19 by Vulpix »
 

Offline Smiling Spectre

  • Jr. Member
  • **
  • Posts: 66
  • Country: 00
  • Karma: 0
Re: Steam protocol
« Reply #153 on: 12 12 2014, 18:52:01 »
After last auto-update Miranda doesn't see the Steam anymore. And it disappeared from the first post too. What the hell?
 

Online Vulpix

Re: Steam protocol
« Reply #154 on: 12 12 2014, 21:26:27 »
Well disappearance from the first post is normal since this is now an actual solution, i.e. shown by plugin updater. But I don't know about it disappearing from Miranda altogether, that shouldn't happen...
 

Offline watcherTopic starter

Re: Steam protocol
« Reply #155 on: 12 12 2014, 23:20:07 »
After last auto-update Miranda doesn't see the Steam anymore. And it disappeared from the first post too. What the hell?

There wasn't anything new, so it wasn't updated. This is what PluginUpdater for - to update only what needed when needed. First post is not needed cause plugin moved to regular repo:

Spoiler

So it can be installed from "Available components" from main menu and auto-updated when there is an actual update, and there wasn't and might not be for a while, this is why:

There is still many small things that could be done, but I'm pretty satisfied with it's current state and my work last days. I need to work on other projects now (no, not Tox :-D ) so I won't be so active here anymore.  :)

Good news are - if there are any updates, including global that somehow will change Steam in any way - no need to worry about updating it anymore - update will arrive with the rest of the plugins.
« Last Edit: 13 12 2014, 07:05:08 by Apollo2k4 »
Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline Smiling Spectre

  • Jr. Member
  • **
  • Posts: 66
  • Country: 00
  • Karma: 0
Re: Steam protocol
« Reply #156 on: 13 12 2014, 10:57:01 »
Aha, it was Steam plugin bug.

For some unknown reason it couldn't be updated (I have no idea why, it haven't any special attributes, can be edited manually, and I was able to remove it after all). If I do "check for updates", it always found new Steam.dll, but not installs it.

As it already installed, it not seen in "Plugin updater" settings.

Simultaneously, it was invisible in "plugins", and didn't work in general.

Fix: remove dll altogether and install it from updater afterwards. :)
 

Offline watcherTopic starter

Re: Steam protocol
« Reply #157 on: 13 12 2014, 11:11:44 »
For some unknown reason it couldn't be updated (I have no idea why, it haven't any special attributes, can be edited manually, and I was able to remove it after all). If I do "check for updates", it always found new Steam.dll, but not installs it.

It's a very rare pluginupdater bug - it writes a wrong hash or something. Very-very rare.
Пожалуйста, внимательно прочтите правила постинга перед тем, как открыть новую тему.
Please read forum rules.
 

Offline Robyer

Re: Steam protocol
« Reply #158 on: 13 12 2014, 11:17:41 »
But seriously, thank you for all the effort!
You're welcome :-)

I also noticed that the people who are playing have a "gamepad" icon of sorts, but I can no longer see which game they are playing (it was showing me that as xstatus before). I have xstatus set as my 3rd row item in clist_modern. Should I change anything according to what you rewrote in the protocol?
It should be in XStatus message, so it seems correct. Do you see xstatuses of other (icq?) people? Do you have enabled visibility of that 3rd line?

You can check with dbeditor - disconnect protocol, open dbeditor and open <contact>/Steam branch, then login and check if "XStatusMsg" key is filled. It is marked as "temporary", that's why you need to have opened DBEditor BEFORE that value is written/changed to see it.

Aldo sometomes Steam doesn't report name of playing game, that could be the case.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Online Vulpix

Re: Steam protocol
« Reply #159 on: 13 12 2014, 14:08:04 »
It should be in XStatus message, so it seems correct. Do you see xstatuses of other (icq?) people? Do you have enabled visibility of that 3rd line?

You can check with dbeditor - disconnect protocol, open dbeditor and open <contact>/Steam branch, then login and check if "XStatusMsg" key is filled. It is marked as "temporary", that's why you need to have opened DBEditor BEFORE that value is written/changed to see it.

Aldo sometomes Steam doesn't report name of playing game, that could be the case.

I'm saying this because I used to be able to see the game :D I have the 3rd row enabled and I have it set correctly to xstatus.

I cannot see any xstatusmsg in database however. The only notion of xstatus is in "UserOnline" where it says "LastXStatusMsg" and shows the name of the game.

The steam protocol itself however only shows "GameInfo" "GameServerID" "GameServerIP"; nothing about xstatus. And I know it worked before. Just to be sure I updated all of the plugins too.
 

Offline Robyer

Re:Steam protocol
« Reply #160 on: 13 12 2014, 14:41:48 »
I'm saying this because I used to be able to see the game :D I have the 3rd row enabled and I have it set correctly to xstatus.

It works for me correctly in clist, tipper, tabsrmm, just everywhere. Before it wasn't saved as XStatus but as standard CList/StatusMsg status message. "Game*" keys are temporary too, so you should(n't) see them either. Weird. Could you try clean development version of whole Miranda+Steam?
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Online Vulpix

Re: Steam protocol
« Reply #161 on: 13 12 2014, 22:58:24 »
Yep when I used it on a clean profile, I can see it correctly:

And when I open the db entry I can see xstatusmsg (game name) and xstatus name ("playing").

On my normal profile, I only see "xstatusID" '730' and then those "Game"-related statuses.

I made sure to use the same version of steam plugin and miranda core, both also x64

What's happening? :o
« Last Edit: 13 12 2014, 23:03:25 by Vulpix »
 

Offline Robyer

Re: Steam protocol
« Reply #162 on: 13 12 2014, 23:31:35 »
What's happening? :o
Idk :) Try cleaning your profile with DbChecker.

Or manually add field XStatusMsg to your contact(s) and check if you see it then. Maybe there is saved some old value...
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Online Vulpix

Re:Steam protocol
« Reply #163 on: 13 12 2014, 23:38:34 »
I tried cleaning it but nothing happened :(

And when I try adding XStatusMsg it doesn't get added. When I tried adding abcdefg then it is added. There seems to be something "broken" that is not allowing XStatusMsg to be added; looks like it's there, but like it's being locked or something.

Any suggestions?

EDIT:

I had a suspicion so I disabled database encryption and voilá there it is. I can see the status just fine then on all of the people playing.

:( so full database encryption breaks xstatusmessage. Can you test this too? Can I report it?
 

Offline Robyer

Re: Steam protocol
« Reply #164 on: 14 12 2014, 10:22:10 »
Vulpix, interesting. Try to consult it with ghazan over jabber. It could be problem in core somewhere.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.