Author Topic: Steam protocol  (Read 110937 times)

0 Members and 1 Guest are viewing this topic.

Offline De7ilx

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
Re: Steam protocol
« Reply #375 on: 06 03 2016, 16:05:31 »
So today I installed this Steam plugin in Miranda. Took the Dev version. Filled in all the information and when I try to set it online simply nothing happens. No error not going online neither.
Does not even ask steam guard code but should.
I already tried to readd the account and reset and so on but nothing makes it work.
Steam named user group exist but is empty.

Netlog is following:
Quote (selected)
[18:03.44 0C74] [STEAM_1] CSteamProto::SetStatus: changing status from 40071 to 40072
[18:03.44 1CB0] [STEAM_1] Send request to https://steamcommunity.com/mobilelogin/getrsakey/
[18:03.44 1CB0] [STEAM_1] Connection request to steamcommunity.com:443 (Flags 11)....
[18:03.44 1CB0] [STEAM_1] (00000000031BDAA8) Connecting to server steamcommunity.com:443....
[18:03.44 1CB0] [STEAM_1] (00000000031BDAA8) Connecting to ip 95.100.3.235:443 ....
[18:03.44 1CB0] [STEAM_1] (1132) Connected to steamcommunity.com:443
[18:03.44 1CB0] [STEAM_1] (1132 steamcommunity.com) Starting SSL negotiation
[18:03.44 1CB0] [STEAM_1] (1132 steamcommunity.com) SSL negotiation successful
[18:03.45 1CB0] [STEAM_1] (00000000031BDAA8:1132) Connection closed internal
[18:03.45 1CB0] [STEAM_1] (00000000031BDAA8:4294967295) Connection closed
[18:03.45 1CB0] [STEAM_1] Send request to https://steamcommunity.com/mobilelogin/dologin/
[18:03.45 1CB0] [STEAM_1] Connection request to steamcommunity.com:443 (Flags 11)....
[18:03.45 1CB0] [STEAM_1] (00000000031BD388) Connecting to server steamcommunity.com:443....
[18:03.45 1CB0] [STEAM_1] (00000000031BD388) Connecting to ip 95.100.3.235:443 ....
[18:03.45 1CB0] [STEAM_1] (1428) Connected to steamcommunity.com:443
[18:03.45 1CB0] [STEAM_1] (1428 steamcommunity.com) Starting SSL negotiation
[18:03.45 1CB0] [STEAM_1] (1428 steamcommunity.com) SSL negotiation successful
[18:03.45 1CB0] [STEAM_1] (00000000031BD388:1428) Connection closed internal
[18:03.45 1CB0] [STEAM_1] (00000000031BD388:4294967295) Connection closed
 

Offline Ratha

  • Jr. Member
  • **
  • Posts: 99
  • Karma: 2
Re: Steam protocol
« Reply #376 on: 07 03 2016, 02:04:51 »
Quote from: Robyer on 06 03 2016, 13:34:05

    If all behaves the same, there is no way to "fix" that.


I tried it using the actual steam web chat, and messages sent by me appear in my opened steam client on my PC. Even if I'm completely signed out of the friends. Incoming messages don't appear in the client, so it's 100% the same behavior as when using miranda and is related to something steam does. Not fixable in miranda I'd say.

Looks like you're right. I could have sworn that i tested this a couple of weeks ago when i first noticed the behavior, but it looks like i must have had steam closed when i did. Just tested it again now and noticed that sending through the web client does indeed cause steam to open its own message window. Makes me wonder why it does that, such a strange behavior.
 

Offline Ratha

  • Jr. Member
  • **
  • Posts: 99
  • Karma: 2
Re: Steam protocol
« Reply #377 on: 07 03 2016, 02:09:58 »
So today I installed this Steam plugin in Miranda. Took the Dev version. Filled in all the information and when I try to set it online simply nothing happens. No error not going online neither.
Does not even ask steam guard code but should.
I already tried to readd the account and reset and so on but nothing makes it work.
Steam named user group exist but is empty.

Have you tried running the updater after installing the Dev version? I had the same problem when i upgraded from 0.95.4 Stable. My update options were still set to the stable version, so after copying the new plugins and things in, and then updating, it was reverting me back to the old version, rather than the Dev version. Check to make sure that your updater is set to Dev Version, and that you've done an update. (Also, you should post your VersionInfo as well so that if thats not the fix, that someone can help figure out what might be going wrong.)

The option is under: Options > Services > Plugin Updater > File Source > Development Version (Less Stable)

Also, make sure that you've set your login name and password in your Main Menu > Account Settings > New Account > Click On Account > Fill in Username + Password
« Last Edit: 07 03 2016, 02:13:00 by Ratha »
 

Offline De7ilx

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
Re: Steam protocol
« Reply #378 on: 07 03 2016, 08:10:44 »
Have you tried running the updater after installing the Dev version? I had the same problem when i upgraded from 0.95.4 Stable. My update options were still set to the stable version, so after copying the new plugins and things in, and then updating, it was reverting me back to the old version, rather than the Dev version. Check to make sure that your updater is set to Dev Version, and that you've done an update. (Also, you should post your VersionInfo as well so that if thats not the fix, that someone can help figure out what might be going wrong.)

The option is under: Options > Services > Plugin Updater > File Source > Development Version (Less Stable)

Also, make sure that you've set your login name and password in your Main Menu > Account Settings > New Account > Click On Account > Fill in Username + Password

Hi,

So I checked and my username and password was present. So that can't be the issue.
I also checked and the Development Version (Less Stable) update option was selected.

So I removed the Steam Plugin once again. Made sure I have Development Version (Less Stable) selected then downloaded the Steam plugin again via plugin downloader. Checked for updates but no updates available. So currently the Steam plugin version is 0.11.5.1 in Plugin list.
So I tried to set it online again but nothing happens. netlog is the following:
Quote (selected)
[10:08.56 080C] [STEAM_1] CSteamProto::SetStatus: changing status from 40071 to 40072
[10:08.56 1EF8] [STEAM_1] Send request to https://steamcommunity.com/mobilelogin/getrsakey/
[10:08.56 1EF8] [STEAM_1] Connection request to steamcommunity.com:443 (Flags 11)....
[10:08.56 1EF8] [STEAM_1] (000000000324ACD8) Connecting to server steamcommunity.com:443....
[10:08.56 1EF8] [STEAM_1] (000000000324ACD8) Connecting to ip 95.100.3.235:443 ....
[10:08.56 1EF8] [STEAM_1] (1144) Connected to steamcommunity.com:443
[10:08.56 1EF8] [STEAM_1] (1144 steamcommunity.com) Starting SSL negotiation
[10:08.56 1EF8] [STEAM_1] (1144 steamcommunity.com) SSL negotiation successful
[10:08.56 1EF8] [STEAM_1] (000000000324ACD8:1144) Connection closed internal
[10:08.56 1EF8] [STEAM_1] (000000000324ACD8:4294967295) Connection closed
[10:08.56 1EF8] [STEAM_1] Send request to https://steamcommunity.com/mobilelogin/dologin/
[10:08.56 1EF8] [STEAM_1] Connection request to steamcommunity.com:443 (Flags 11)....
[10:08.56 1EF8] [STEAM_1] (000000000324A488) Connecting to server steamcommunity.com:443....
[10:08.56 1EF8] [STEAM_1] (000000000324A488) Connecting to ip 95.100.3.235:443 ....
[10:08.56 1EF8] [STEAM_1] (1444) Connected to steamcommunity.com:443
[10:08.56 1EF8] [STEAM_1] (1444 steamcommunity.com) Starting SSL negotiation
[10:08.56 1EF8] [STEAM_1] (1444 steamcommunity.com) SSL negotiation successful
[10:08.57 1EF8] [STEAM_1] (000000000324A488:1444) Connection closed internal
[10:08.57 1EF8] [STEAM_1] (000000000324A488:4294967295) Connection closed
 

Offline jjamesville

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
Re: Steam protocol
« Reply #379 on: 08 03 2016, 02:53:57 »
Do you keep a changelog anywhere else? I like to check here from time to time to see if any features have been added but most posts are just error reporting.
 

Offline Vulpix

  • Beta Tester
  • *****
  • Posts: 614
  • Country: 00
  • Karma: 15
Re: Steam protocol
« Reply #380 on: 08 03 2016, 07:10:11 »
Do you keep a changelog anywhere else? I like to check here from time to time to see if any features have been added but most posts are just error reporting.

Here: http://trac.miranda-ng.org/log/trunk/protocols/Steam
 
The following users thanked this post: jjamesville

Offline Ratha

  • Jr. Member
  • **
  • Posts: 99
  • Karma: 2
Re: Steam protocol
« Reply #381 on: 08 03 2016, 07:59:14 »
Hi,

So I checked and my username and password was present. So that can't be the issue.
I also checked and the Development Version (Less Stable) update option was selected.

So I removed the Steam Plugin once again. Made sure I have Development Version (Less Stable) selected then downloaded the Steam plugin again via plugin downloader. Checked for updates but no updates available. So currently the Steam plugin version is 0.11.5.1 in Plugin list.
So I tried to set it online again but nothing happens. netlog is the following:

Please attach your Version Information so that we can help figure out what is going on.

To make sure that your copy or settings in Miranda are not the cause of the problem:
1: Download a clean copy of Miranda NG 0.95.5 Dev
2: Install the Steam plugin (and the steam icons plugin?)
3: Add your Steam account to the accounts page, enter your username and password.
4: Run the updater and restart Miranda.
5: Try to go Online with Steam. It should pop up a box asking you to check your email for the authorization code.
6: Enter the auth code from your email into the Miranda popup that asks for it.
7: Successfully login?
 

Offline De7ilx

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
Re: Steam protocol
« Reply #382 on: 08 03 2016, 09:15:41 »
Please attach your Version Information so that we can help figure out what is going on.

To make sure that your copy or settings in Miranda are not the cause of the problem:
1: Download a clean copy of Miranda NG 0.95.5 Dev
2: Install the Steam plugin (and the steam icons plugin?)
3: Add your Steam account to the accounts page, enter your username and password.
4: Run the updater and restart Miranda.
5: Try to go Online with Steam. It should pop up a box asking you to check your email for the authorization code.
6: Enter the auth code from your email into the Miranda popup that asks for it.
7: Successfully login?

So first of all I am posting my normal Miranda installation version in attachments here.

Then I did all steps from 1 to 5 but no box popped up. netlog is exactly the same as main installation has.
So clean install and old install has exactly the same issue.
Just in case adding the netlog aswell:
Quote (selected)
[11:07.55 1440] [STEAM_1] CSteamProto::SetStatus: changing status from 40071 to 40072
[11:07.55 1CC4] [STEAM_1] Send request to https://steamcommunity.com/mobilelogin/getrsakey/
[11:07.55 1CC4] [STEAM_1] Connection request to steamcommunity.com:443 (Flags 11)....
[11:07.55 1CC4] [STEAM_1] (0000000002565E58) Connecting to server steamcommunity.com:443....
[11:07.55 1CC4] [STEAM_1] (0000000002565E58) Connecting to ip 23.32.89.112:443 ....
[11:07.55 1CC4] [STEAM_1] (1204) Connected to steamcommunity.com:443
[11:07.55 1CC4] [STEAM_1] (1204 steamcommunity.com) Starting SSL negotiation
[11:07.55 1CC4] [STEAM_1] (1204 steamcommunity.com) SSL negotiation successful
[11:07.56 1CC4] [STEAM_1] (0000000002565E58:1204) Connection closed internal
[11:07.56 1CC4] [STEAM_1] (0000000002565E58:4294967295) Connection closed
[11:07.56 1CC4] [STEAM_1] Send request to https://steamcommunity.com/mobilelogin/dologin/
[11:07.56 1CC4] [STEAM_1] Connection request to steamcommunity.com:443 (Flags 11)....
[11:07.56 1CC4] [STEAM_1] (000000000253C5F8) Connecting to server steamcommunity.com:443....
[11:07.56 1CC4] [STEAM_1] (000000000253C5F8) Connecting to ip 23.32.89.112:443 ....
[11:07.56 1CC4] [STEAM_1] (1440) Connected to steamcommunity.com:443
[11:07.56 1CC4] [STEAM_1] (1440 steamcommunity.com) Starting SSL negotiation
[11:07.56 1CC4] [STEAM_1] (1440 steamcommunity.com) SSL negotiation successful
[11:07.57 1CC4] [STEAM_1] (000000000253C5F8:1440) Connection closed internal
[11:07.57 1CC4] [STEAM_1] (000000000253C5F8:4294967295) Connection closed
 

Offline Robyer

  • Hero Member
  • *****
  • Posts: 1082
  • Country: cz
  • Karma: 60
    • Robyer.cz website
  • Version Info
Re: Steam protocol
« Reply #383 on: 08 03 2016, 12:55:38 »
De7ilx, try to login via Pidgin (with their Steam plugin) and let me know if it works there.
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline De7ilx

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
Re: Steam protocol
« Reply #384 on: 08 03 2016, 13:18:36 »
De7ilx, try to login via Pidgin (with their Steam plugin) and let me know if it works there.

Ok I tried and it says de7ilx disconnected Connection timed out.
 

Offline Robyer

  • Hero Member
  • *****
  • Posts: 1082
  • Country: cz
  • Karma: 60
    • Robyer.cz website
  • Version Info
Re: Steam protocol
« Reply #385 on: 08 03 2016, 14:53:36 »
De7ilx, so it doesn't work there. You can also try official Android application, or use web browser variant of Steam chat - https://steamcommunity.com/chat , maybe it will give you better error message or maybe it will work...
I was developing mainly Facebook, Omegle, Steam, Dummy and MobileState plugins. Now I'm retired. Goodbye, everyone. ~ You can still find me on Facebook.
 

Offline De7ilx

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
Re: Steam protocol
« Reply #386 on: 08 03 2016, 16:11:42 »
De7ilx, so it doesn't work there. You can also try official Android application, or use web browser variant of Steam chat - https://steamcommunity.com/chat , maybe it will give you better error message or maybe it will work...
Both Official Android app and web steam chat works just fine. Since they are made by steam.
 

Offline Ratha

  • Jr. Member
  • **
  • Posts: 99
  • Karma: 2
Re: Steam protocol
« Reply #387 on: 10 03 2016, 04:16:36 »
De7ilx, heres a few things to look into:

- Perhaps theres a firewall or antivirus thats blocking the connection? You said Pidgin's Steam protocol didnt work either which makes me think its a system or network configuration problem of some sort? Assuming that the problem isnt directly related to windows 10 as im not sure if the protocol works on Win10.

- Are you trying to connect from home, or from a business / coffee shop / work that could be blocking your connection? Are you able to login to both the steam store page and the steam community from within your web browser? Do you have Steam installed? (I think you said the android app worked, but what about Steam itself?)

- Does your windows user folder use any special characters in its name? Any characters which are not A-Z + 0-9? Your version info mentioned: OS Languages: (UI | Locale (User/System)) : English/English | Estonian/Estonian and special characters in path/filenames have been known to cause odd sorts of problems in various programs. (Your Miranda profile does not look like its stored in your windows user folder so i wouldnt think that would cause the problem.)

Could the problem be caused by having mobile authorization enabled on his account? His netlog login is trying to connect to https://steamcommunity.com/mobilelogin/getrsakey/ where as mine tries to connect to https://api.steampowered.com/ISteamWebUserPresenceOAuth/Logon/v0001 . Currently i do not have mobile auth enabled for my steam profile settings. Is the popup / auth window somehow dependent upon not having mobile enabled? Just taking a wild guess at something that could have been overlooked since i cant confirm it myself.

(Below is a copy of a successful login from offline status using a previously steamguard-authorized connection. I didnt have time to log out completely and grab a netlog of the re-authorization process for comparison purposes, and i have sanitized any potentially sensitive information from this log by replacing with [Removed] )
Quote (selected)
[20:20:43 3284] [Steam_Ratha] CSteamProto::SetStatus: changing status from 40071 to 40072
[20:20:43 0D3C] [Steam_Ratha] Send request to https://api.steampowered.com/ISteamWebUserPresenceOAuth/Logon/v0001
[20:20:43 0D3C] [Steam_Ratha] Connection request to api.steampowered.com:443 (Flags 11)....
[20:20:43 0D3C] [Steam_Ratha] ([Removed]) Connecting to server api.steampowered.com:443....
[20:20:43 0D3C] [Steam_Ratha] ([Removed]) Connecting to ip 23.200.219.187:443 ....
[20:20:43 0D3C] [Steam_Ratha] ([Removed]) Connected to api.steampowered.com:443
[20:20:43 0D3C] [Steam_Ratha] ([Removed] api.steampowered.com) Starting SSL negotiation
[20:20:43 0D3C] [Steam_Ratha] ([Removed] api.steampowered.com) SSL negotiation successful
[20:20:43 0D3C] [Steam_Ratha] ([Removed]:[Removed]) Data received
HTTP/1.1 200 OK
[20:20:43 0D3C] [Steam_Ratha] ([Removed]:[Removed]) Data received
Content-Type: application/json; charset=UTF-8
Content-Length: 167
Expires: [Removed]
Date: [Removed]
Connection: close
 

Offline Vulpix

  • Beta Tester
  • *****
  • Posts: 614
  • Country: 00
  • Karma: 15
Re: Steam protocol
« Reply #388 on: 10 03 2016, 07:27:57 »
- Perhaps theres a firewall or antivirus thats blocking the connection? You said Pidgin's Steam protocol didnt work either which makes me think its a system or network configuration problem of some sort? Assuming that the problem isnt directly related to windows 10 as im not sure if the protocol works on Win10.

I use w10, steam works here without any issues.
 

Offline De7ilx

  • Newbie
  • *
  • Posts: 7
  • Karma: 0
Re: Steam protocol
« Reply #389 on: 10 03 2016, 08:08:46 »
De7ilx, heres a few things to look into:

- Perhaps theres a firewall or antivirus thats blocking the connection? You said Pidgin's Steam protocol didnt work either which makes me think its a system or network configuration problem of some sort? Assuming that the problem isnt directly related to windows 10 as im not sure if the protocol works on Win10.

- Are you trying to connect from home, or from a business / coffee shop / work that could be blocking your connection? Are you able to login to both the steam store page and the steam community from within your web browser? Do you have Steam installed? (I think you said the android app worked, but what about Steam itself?)

- Does your windows user folder use any special characters in its name? Any characters which are not A-Z + 0-9? Your version info mentioned: OS Languages: (UI | Locale (User/System)) : English/English | Estonian/Estonian and special characters in path/filenames have been known to cause odd sorts of problems in various programs. (Your Miranda profile does not look like its stored in your windows user folder so i wouldnt think that would cause the problem.)

Could the problem be caused by having mobile authorization enabled on his account? His netlog login is trying to connect to https://steamcommunity.com/mobilelogin/getrsakey/ where as mine tries to connect to https://api.steampowered.com/ISteamWebUserPresenceOAuth/Logon/v0001 . Currently i do not have mobile auth enabled for my steam profile settings. Is the popup / auth window somehow dependent upon not having mobile enabled? Just taking a wild guess at something that could have been overlooked since i cant confirm it myself.

(Below is a copy of a successful login from offline status using a previously steamguard-authorized connection. I didnt have time to log out completely and grab a netlog of the re-authorization process for comparison purposes, and i have sanitized any potentially sensitive information from this log by replacing with [Removed] )

Okay to go thru the points:
- I added firewall exception and it did not fix the issue.
- I am trying to connect from the home and as far as I know nothing is blocking the connection. I use Windows 10 Pro.
- No my folder uses all English characters and nothing special.
- I do have mobile authorization enabled on my account. So when I log in thru web browser I take my code from the mobile app to enter. Not by e-mail.
Also normal steam works on my machine. And I can also log into steam from browser.

Most probable guess is that the issue could be that I have the mobile auth enabled on my account and the steam protocol on Miranda simply does not know how to handle the pop up for mobile auth.

EDIT: I have confirmed that the issue is indeed caused by the Mobile auth. I used my gf account who does not have the mobile auth enabled and for her account everything worked. So is it something that could be fixed? So the Steam protocol in Miranda could also work with mobile Auth ?
« Last Edit: 10 03 2016, 08:18:41 by De7ilx »