Miranda NG Official Community Forum

Forum for English speaking Miranda NG users => Miranda NG general talk => Topic started by: Scrappy on 20 09 2014, 10:31:46

Title: Twitter
Post by: Scrappy on 20 09 2014, 10:31:46
...ok it might sound a little bit stupid but where can i enter my twitter username ?  :-\ . When adding the twitter protocol there is no place i see that asks that.. ??? Maybe its me but well i don't know at the moment. I have a twitter acount and don't want to create another one.
Title: Re: Twitter
Post by: Robyer on 20 09 2014, 15:55:51
Scrappy, if I remember correctly, when you first switch protocol to Online, it should open webbrowser with Twitter API confirmation or something like that. Have you tried that?

But it's weird that in accounts manager is only "Username" label and no editbox. It should inform user in a better way what he should do...
Title: Re: Twitter
Post by: Scrappy on 20 09 2014, 17:05:52
first thanks for the response.

well when i first set the protocol to online it just wants to connect but nothing happens. I have removed and added the protocol many times but nothing works (it did in the past as far as i know) :-[
It looks like it wants to connect but with no username or something like that  :-\ .
There is not one moment that is asks for my twitter username, only a accountname (is that the username ?) but that doesn't work either.
Title: Re: Twitter
Post by: Robyer on 20 09 2014, 18:48:10
I created new account, switched to online and it immediatelly showed dialog to add Twitter PIN and opened website to authorize Miranda. Try to delete and recreate your twitter account in Miranda.

Btw I'm testing it on development version, maybe it's broken on stable?
Title: Re: Twitter
Post by: Scrappy on 22 09 2014, 08:36:05
switched to online and it immediatelly showed dialog to add Twitter PIN and opened website to authorize Miranda

well that doesn't happen here  :-[ . Tryed the latest stable and unstable 64bit versions but no dice. I don't get a twitter PIN it just wants to connect but it has no twitter user name........
Title: Re: Twitter
Post by: Robyer on 22 09 2014, 14:26:12
Maybe it's a problem in 64 bit version. If I remember correctly then similar problem was with Steam protocol.
Title: Re: Twitter
Post by: Vulpix on 22 09 2014, 14:36:57
Yep, kind of.

I had an issue where I once didn't know that I would get the authentication widow and I closed miranda under the impression I had missed something (to input the SteamGuard code into). When I started miranda again and tried to connect, I never got the authentication window again.

To solve this, I logged in to steam from the actual application and revoked login permissions for all of the authenticated connections. Upon next miranda login, I was presented with the steamguard input box again and this time I didn't miss it.

Can you somehow revoke authentication of your attached twitter devices? It may be worth a shot.
Title: Re: Twitter
Post by: Scrappy on 01 10 2014, 12:42:54
I revoked all authentication in twitter for any Miranda access but still it won't come up with a new request.........
Title: Re: Twitter
Post by: Scrappy on 05 10 2014, 07:03:41
....can i use the 32bit version in a 64bit miranda ??
Title: Re: Twitter
Post by: watcher on 05 10 2014, 07:22:56
Scrappy, no - you can't.

Post Merge: 05 10 2014, 07:24:04
But you can try a fresh 32-bit miranda to see id problem presists for you. Just for testing.
Title: Re: Twitter
Post by: Scrappy on 12 10 2014, 11:23:20
ok started a clean miranda ng 32b version with stable 32b twitter plugin. All auth. for twitter are still revoked in twitter account. Starting miranda and adding a twitter account results in a message "  OAuth Tokens not received, check your internet connection? " when i set the plugin online. I have internet connection. Tested that with adding another plugin (ICQ) and that works.
Title: Re: Twitter
Post by: watcher on 12 10 2014, 12:31:51
I've just tried and got authorized. 32-bit Miranda.
Title: Re: Twitter
Post by: Scrappy on 13 10 2014, 18:40:54
Thx all for replying/helping

twitter is working again, had some problems with torrents and a game so i cleaned everything up, registry - defrag - optimize - new wlan driver,
and just now after reading watcher's reply i started miranda ng and set twitter online (64b version) and a popup came asking a twitter pin !!!!

pffff dont know what did the trick but i am glad it works again !!

THX ALL !!!   :DRINK: